URGENT HELP NEEDED Packaging Problem

When packaging my project i get Program.Main: AutomationTool exiting with ExitCode=25 (Error_UnknownCookFailure)
along with some other errors. I’ve got a grad show coming up and really need my project packaged. I found that if I delete my folder that contains ALL of my essential blueprints such as player controllers and UMG files I can package the project which leads me to think one of the blueprints is the problem. However I have tried deleting them one by one to find the one which is a problem only to find the error only goes away if ALL of them are deleted. Iv’e tralled the internet for soloutions, changed packaging settings and nothing seems to help. Please if someone could help me I’d appreciate it.

Packaging log

Hello DavidosLeonard,

I’ve seen this error before, in particular this one:

Assertion failed: Pair != nullptr [File:D:\BuildFarm\buildmachine_++UE4+Release-4.11\Engine\Source\Runtime\Core\Public\Containers\Map.h] [Line: 520]

The AutomationTool failing is basically just saying that it failed, but not giving any kind of details. Are you doing anything with TMaps? It seems to be failing due to some kind of use of those. It also may be located inside of TutorialHUD, as that was the last thing that was being cooked before the failure but that could be a coincidence. I’ll be looking into it more but I wanted to at least point you towards the error in the meantime.

I don’t really know what tmaps are so doubt Iv’e dabbled with them. I tried deleting Tutorial HUD and everything referencing to it and still get the same crash.

Edit: if by my understanding a Tmap is a texture map, I have a few emmisive tron like materials I created. Don’t know if they would be causing trouble.

Sorry to bother you Matthew bu I wondered if you discovered anything about this error, I’m running out of time before I need to present my game and I really have ran out of things to try to fix this…

Hello DavidosLeonard,

I apologize for the delay, but I was unavailable for the weekend. It took a bit of digging but I found an old post where I helped someone with this same issue. Can you take a look at the answer posted here and see if it is able to fix the problem for you?

Hi Matthew, no worries about the delay. I followed the link and I’d already tried all those solutions (installing the correct parts of visual studio) and adding the maps - still get the exact same ■■■■ error. I also tried migrating and copy and pasting the contents into a fresh new build. If I migrate just one of my blueprints the exact same error appears (without them a clean project packages correctly) I really feel like I’m out of options at this point.

As far as logging this packaging attempt goes, one huge thing that is missing from the log is the callstack. I have a feeling this may be due to not having the “Editor Symbols for Debugging” installed, which was an option added to your installation of the engine in 4.10 and disabled by default. Could you open the launcher’s Library tab, click the down arrow beside your 4.11 installation, and select Options? From the window that pops up, there should be a checkbox for the symbols. Please check that and let it install them. After this is done, please try packaging again and upload the new logs. Hopefully this’ll allow it to log the callstack directly which should give us an idea of where the error is occurring.

Went ahead and got the results with the debug link text

Unfortunately, the call stack is still blank. In case you’re curious, the callstack would be in that blank space below the Assert message about TMaps.

Also TMaps are sort of like a mix between an array and an enumerator, if you know what those are. You can find more on TMaps themselves here: TMap | Unreal Engine Documentation

I’m continuing to look into what could be causing the callstack to be blank like that, as it seems like our best bet to finding out what is going on. I’ll get back to you as soon as I can.

Would it be possible for you to send a copy of your project so that we can reproduce the problem locally and run some debugging on the process? If you wish for it to remain private, you could send a link to the download to me through a private message on our forums.

Sent you a link Matthew, hopefully you have more luck with it than I have :smiley:

Thank you for that. From what we’ve been able to see so far, the main offender here seems to be the TutorialHUD asset. When removing this asset and all references to it, it seems to allow the packaging process to go through fine. We’re still looking into exactly why this is happening but this may be able to help you in the meantime while we search for a proper fix.

No problem, and thank you. That’s interesting, might be to do with the animations popping off in the UMG.

Right so Iv’e done the same as you and turns out your right, the problem is the tutorial UMG - yet I cant for the life of me figure out what it is specifically that crashes it. I removed the references such as the variables being added while keeping the actual UMG file in and that crashes it. To me that suggests the TutoiralHUD itself alone is the problem. Can’t figure out what it is that’s crashing it but i’d put my money on the animation’s. Any thoughts?

Hello DavidosLeonard,

I apologize for the delay, but I took some time to look over the TutorialHUD blueprint and I think I found the problem. It seems like the LevelReference variable you have in the TutorialHUD class is causing this packaging problem. Removing the variable allowed the packaging process to proceed without an issue, albeit there were still quite a few warnings. It doesn’t seem as though it was being used for anything as well. Seeing as the level blueprint changes for each map, I don’t think storing it here would be a good idea.

Hope this helps!

Tried this Matthew and it works like a charm! I can finally package my game for use in places like indie db! I see your marked as staff and while you will likely say ‘well it’s my job’ I’d like to thank you sincerely for helping me with this issue. I felt like it was something in my build that was totally broken and I can’t thank you enough for you help!

I’m glad to hear that it worked. It is my job but it’s still good to hear gratitude so I appreciate it.

Have a good day!