Urgent Bug, Now Locked Out Of Project

Hey Guys,

I have a serious issue on my hands and can no longer get into my project. When working on fixing an issue I had reported to TJ earlier, I happened to change the projects starting level to my Title_Screen level and then tried to load it, got the following crash and now get this crash every time I load my project. I love using Blueprints but this kind of stuff scares me and was touched upon in the last Twitch Stream.

I know I have a couple options here to save things and I’ll try going through my configs and see if I can manually change the starting map. From there I’ll simply try to fix the redirectors of that directory where the BP is located but not sure if that will do anything. If that doesn’t work, I’ll try to recompile the BP or just use a previous backup but I’m nearing the final stages of having something to show off and my prototype that I’ve been working on for the past couple of months and is roughly 99% Blueprints so I hope I don’t unfortunately end up in a bad situation.


Renaming an object (MainMenuItem_C /Game/Maps/Core/Title_Screen.Title_Screen:PersistentLevel.MainMenuItem_C_4) on top of an existing object (MainMenuItem_C /Game/Maps/Core/Title_Screen.Title_Screen:PersistentLevel.MainMenuItem_C_8) is not allowed

Address = 0x84815bf8 (filename not found) [in C:\Windows\system32\KERNELBASE.dll]
FOutputDeviceWindowsError::Serialize() 0x79690a13 + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:113] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-Core.dll]
FMsg::Logf__VA() 0x7955d5aa + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\core\private\misc\outputdevice.cpp:547] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-Core.dll]
UObject::Rename() 0x791d179a + 138 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\coreuobject\private\uobject\obj.cpp:87] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-CoreUObject.dll]
AActor::Rename() 0x625279ed + 18 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\engine\private\actor.cpp:703] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-Engine.dll]
UChildActorComponent::ApplyComponentInstanceData() 0x625d61da + 55 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\engine\private\childactorcomponent.cpp:98] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-Engine.dll]
FComponentInstanceDataCache::ApplyToActor() 0x625d6571 + 31 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\engine\private\componentinstancedatacache.cpp:116] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-Engine.dll]
AActor::ExecuteConstruction() 0x624f32e7 + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\engine\private\actorconstruction.cpp:355] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-Engine.dll]
AActor::RerunConstructionScripts() 0x62528d13 + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\engine\private\actorconstruction.cpp:263] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-Engine.dll]
ULevel::IncrementalUpdateComponents() 0x627fc02a + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\engine\private\level.cpp:815] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-Engine.dll]
UWorld::UpdateWorldComponents() 0x62c86370 + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\engine\private\world.cpp:1268] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-Engine.dll]
FUnrealEdMisc::CB_MapChange() 0x6f39babd + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\editor\unrealed\private\unrealedmisc.cpp:698] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
TBaseRawMethodDelegateInstance_OneParam::ExecuteIfSafe() 0x6f3c61ea + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\core\public\delegates\delegateinstancesimpl.inl:359] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
TBaseMulticastDelegate_OneParam::Broadcast() 0x6f0932d2 + 13 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\core\public\delegates\delegatesignatureimpl.inl:1852] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
UEditorEngine::Map_Load() 0x6f0beff1 + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\editor\unrealed\private\editorserver.cpp:2243] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
UEditorEngine::HandleMapCommand() 0x6f0b0ebd + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\editor\unrealed\private\editorserver.cpp:5572] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
UEditorEngine::Exec() 0x6f09c841 + 21 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\editor\unrealed\private\editorserver.cpp:5053] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
UUnrealEdEngine::Exec() 0x6f3bc8d0 + 17 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\editor\unrealed\private\unrealedsrv.cpp:704] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
FEditorFileUtils::LoadMap() 0x6f120ce4 + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\editor\unrealed\private\filehelpers.cpp:1753] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
FEditorFileUtils::LoadDefaultMapAtStartup() 0x6f1209a8 + 56 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\editor\unrealed\private\filehelpers.cpp:2858] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
FUnrealEdMisc::OnInit() 0x6f3ec8c0 + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\editor\unrealed\private\unrealedmisc.cpp:182] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
EditorInit() 0x6f3bb850 + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\editor\unrealed\private\unrealed.cpp:88] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor-UnrealEd.dll]
GuardedMain() 0xd6acd17d + 0 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\launch\private\launch.cpp:125] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor.exe]
GuardedMainWrapper() 0xd6acd2aa + 5 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\launch\private\windows\launchwindows.cpp:125] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor.exe]
WinMain() 0xd6ad91c9 + 17 bytes [File=d:\unreal engine 4\source\unrealengine-4.4.1-release\engine\source\runtime\launch\private\windows\launchwindows.cpp:201] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor.exe]
__tmainCRTStartup() 0xd6ada089 + 21 bytes [File=f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618] [in D:\Unreal Engine 4\Source\UnrealEngine-4.4.1-release\Engine\Binaries\Win64\UE4Editor.exe]
Address = 0x866116ad (filename not found) [in C:\Windows\system32\KERNEL32.DLL]
Address = 0x874434a5 (filename not found) [in C:\Windows\SYSTEM32\ntdll.dll]
Address = 0x874434a5 (filename not found) [in C:\Windows\SYSTEM32\ntdll.dll]

I was able to get into the config and set a different level as the starting one and was able to get into the editor but I cannot figure out what is causing this “rename” issue. I can open the Blueprints in question and they compile fine, this only happens when I try to load the level.

I tried going through all my files and only did the original backup from this morning that it worked but now I’ve lost all my work for the day which isn’t the end of the world, but a huge letdown. I’d like to see if I can fix what I did work on today with you guys but I’ve seen this error about renaming things before. It happens in my case when a given BP is placed within the level throwing the error. I’m going to try to keep moving forward but if anyone has any idea what is causing this, let me know. I may try to compile a debug build of the engine tonight and see if I can catch the actual exception that is throwing. Thanks.

Hi MC Stryker,

I’m sorry you’ve been having this issue. It seems from above that you are at least back in your project and working. I will get with some of our developers and see if we can get more info on this renaming problem.

Hey TJ. Yea, I got into last night changing the starting map in the DefaultEditor.ini I believe. Sounds great. Since I was able to at least get into the engine, and this specifically relates to my title screen, I can thankfully continue working until I am able to resolve this with you guys. Appreciate it TJ!

So I just encountered this issue again after working on that backup that worked. Thankfully I saved a copy of it before making the changes but I’ve lost a couple more hours of work again. Not to thrilled right now.

I know it has to do with the instance of the Blueprint within the level being different than the one in my content library. Out of paranoia, I edited my MainMenu BP outside of the level it’s used on and after going back into the level after working on it, it crashed again.

Has there been an update on any potential findings on what is causing this? It is the same renaming bug I posted above.

EDIT: One other thing is these types of issues have plagued me in the past. If a BP that is being used on a level is changed outside of that level, it can lead to issues like this. There needs to be some way for the engine to see these changes maybe that are causing this renaming bug or others and to notify the user that there are dependency changes and if they want to proceed, to opt in to fix the dependencies.


Hi MCStryker,

Nothing yet but I am working with our Blueprint team to try and find a solution/explanation for you. We’ll post back soon as possible.

Awesome, glad to hear TJ! I’ve nearly converted all of those TextRenderComponents but I’m now saving and re-compiling constantly as well as editing those BPs on the level they are used. I should be able to get past this but I’m hoping the team can fix the underlying issue. Thanks again TJ!

Hi MCStryker,

I spoke with one of our devs and he said that the Github fix I referred you to in the other post was actually meant to fix this issue. Could you give it a try if you haven’t integrated it already?


Whoops, that makes sense. (Facepalm) I didn’t pull that down after upgrading to 4.4.3… ah that’s my fault :P. I’ll go pull that down but tell that developer thanks! If that is a proper fix, then I’ll go ahead and get that going and for the time being, I’ll mark your post above as the answer and if this comes back to haunt me, I’ll fill you in. Thanks again TJ!