.uprojectファイルが関連付けされません

UE4のアカウントを持ち、古いPCではちゃんと動いていました。この度、新しいPCを購入しUE4のランチャーをインストールしたのですが、マイプロジェクト(ランチャー)にあるサムネイルからプロジェクトを開こうとするのですが、

指定されたファイルに対応してこの操作を行うプログラムが関連付けされていません。プログラムをインストールするか、すでにプログラムがインストールされて場合はコントロールパネルの…でプログラムを関連図けて下さい。

と表示され、起動できません。.uprojectファイルのアイコンも真っ白な普通のファイルのままです。
左に表示されているエンジンを起動(黄色のボタン)でエンジンを起動してから表示されるプロジェクトブラウザからは作成されたプロジェクトは起動できます。
ランチャーインストラーから修復インストールをしたり、英語版のランチャーにしたり、2バージョンのue4(4.17)をインストールしたり、過去の投稿の回答にあるようにProgramDataフォルダなどに残っているファイルを削除してみたり2日あまりインストールしたりアンインストールをしたりを繰り返しています。
 アセットのセール中ではありますが、どなたか解決方法を教えていただけないでしょうか?
ちなみにOSはWindows10でインストラーは7.5.0です。
言葉が足りないかもしれませんが、よろしくお願いいたします。

以前似たような経験をした時は再インストールで直ったのですが、それで直らないとの事なので以下の方法を試してみてください。

右クリックコンテキストメニュー > プログラムから開く > 別のプログラムを選択

「Unreal Engine」があればそれを選択。無ければ、その他のアプリで「Unreal Engine」を探して選択。

その他のアプリ欄になければ Unreal Engine が正しく認識されていないかもしれないですね。

例えば日本語パスにしているとかは原則NGです。

ご回答ありがとうございました。 この方法で起動できました。
がしかし、アイコンの色が以前は青色であり、今回は黒色です。
右クリックメニューでSwitch engine versionやGenerate project Fileの項目がありません。
ちなみにですが、インストールを繰り返していた時にUnrealVersionSelector(ランチャーがインストールされているフォルダ)
 右クリックコンテキストメニュー > プログラムから開く > 別のプログラムを選択 
で選択したことがあったのですが、
 引数が足りません。
みたいなエラーメッセージが出てダメでした。
一応、エディタを2回、立ち上げなくてすむようになりました。
ありがとうございます。
他の方のご回答があるかもしれないので解決済みのチェックは暫らくは入れないでおきます。

たびたびすみませんが、
>例えば日本語パスにしているとかは原則NGです。
Windows10を標準インストールをしたらC:¥Usersフォルダーの表示が日本語で‘ユーザー‘となります。
コマンドプロンプトではチャンとC:¥Users¥UserNameになっていますが、エクスプローラでは‘ユーザー‘と日本語表示されています。これが原因なのでしょうか?

そういえばレジストリ内で多くの関連付けを行っているので、暫定対処でしかなかったですね。

「Users」フォルダがエクスプローラー上で日本語表記になっているのとは関係ありません。

なぜユーザーフォルダが出てきたのか気になるのですが、インストール先をユーザーフォルダ内にしているとかはないですよね?

いつも大変お世話になっております。

>インストール先をユーザーフォルダ内にしているとかはないですよね?

インストールの場所はProgramFiles(x86)です。古いPCもUsersフォルダーが“ユーザー”と表示されていたので勘違いしていたようです。すみませんでした。
とりあえずご報告をば…。

こちらでも同様の現象に見舞われまして、解決策を1つ見つけたのでご報告致します。
C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64
UnrealVersionSelector.exe
をコピー

C:\Program Files\Epic Games\エンジンバージョン\Engine\Binaries\Win64
に貼り付け

UnrealVersionSelector.exeをダブルクリック

レジスター~~~と出ますが、「OK」を選択してSuccsessと出たら成功

開きたい.uprojectファイルを右クリックして、エンジンバージョンを選択できれば成功

この際まだ、アイコンが出ていませんが再起動すればアイコンが出るようになります。

上記の方法でこちらでは解決しましたが、ここ数日以内にUE4のインストールを
行った場合だけ現象が発生したため、ランチャーのアップデート不具合の可能性が高いかと・・・

Oyamada様、無事解決いたしました!
ご苦労されて手に入れられた御情報をご教授下さり、大変ありがとうございました。
助かりました。
Chori様も色々なご回答ありがとうございました。