UProject solution generation problem with Vulkan API


After i’ve downloaded Vulkan API and installed it on my PC, i cannot generate visual studio project files.
This error shows up :

I’ve tried to uninstall Vulkan API, but it did not helped.
Any ideas on what could be the problem ?

This error comes from MissingModuleException.

Checking the build system this comes from an environmental variable:

string VulkanSDKPath = Environment.GetEnvironmentVariable("VK_SDK_PATH");

Do you know how to check environment variables? Looks like you’re using windows. One way is a command window and type


Can you check at that folder that it’s not empty? Maybe it’s in a new location? Kinda guessing here as I’ve never played with this.

No worries,I just picked something randomly :stuck_out_tongue:

The environment variable points to a folder.

However I realised I wasn’t checking the code from your version.

In UEBuildWindows.cs is commented out:

         if ((!String.IsNullOrEmpty(VulkanSDKPath)))

Can you check if that’s the case for you? Other than that… I’m not too sure.

I’d be curious to see the rest of your command line arguments from your screenshot.

EDIT: sorry didn’t reply, I’m new to answer hub :stuck_out_tongue:

Hey, thanks for a quick answer :slight_smile:

  1. I checked the env variables, there is no sign of anything related to Vulkan (Yes its Windows 7).

  2. What folder ?

Also, i’ve removed Vulkan from my PC, project launching is more important, however its remaining’s are preventing me from making source files (and making a successful build). Do you know perhaps what should be done to remove those remainings ?


Problem solved, but in a very weird way, i’ve just copied and pasted the engine from to another drive, and back, and it worked :P. Though if anyone will have the similar issue, i recommend to try Bino’s solution.

By the way, thanks for your help :slight_smile:

I guess when in doubt re-install always works!