.uproject problem or running editor problems

Okay, so I wiped my laptop and started fresh. Downloaded Unreal Engine, installed it which was fine. So I installed the first engine version that had just came out which is 4.15.1. I created a project and it worked nice, this version is actually smoother than the other ones I tried to work with but after I was finished. Obviously, I saved the project and I went back to it later. This was when this crazy stuff starts happening. So I tried opening my project from the normal menu on Unreal Engine, I got this message. “This file does not have a program associated with it for performing this action. Please install a program or, if one is already installed create an association is the Default Programs control panel.” I uninstalled, repaired, I tried everything I could. So after hours if researching the problem. I found nothing. No breakthroughs, no solutions. I went to the file location, basically to where the project was saved in the file. It looked like that.

132494-unrealproblem.png

When I left click on it, it tells me to download an app for it to run on. Right click on it, menu comes up but with no helpful ideas. Please help!

what happens if you right-click the file and select open withchoose another app and then manually point to the editor binary file?

I found this answer elsewhere but it worked for me and reportedly fixed the issue for others too. This method should give you the wanted context menu back to .uproject-files and associate the project for engine so you can open it via launcher.

Try this:

Take this file: “C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64\UnrealVersionSelector.exe”.
And paste it into “C:\Program Files\Epic Games\UE_4.15\Engine\Binaries\Win64” then double click it.

Just had the same issue with 4.21 and this solution still worked!!! Thanks!