.uproject missing in packaged project

Alright, so today I wanted to release an alpha version of my game for public testing. First ever release of the game in fact. Packaging it went well. No errors were reported. BUT, I ran into an issue when testing to see if the new package would actually work. At first I had used a development configuration, and when I opened the .exe in the root of the package folder, it gave me a black screen, with a dialog box saying “Fatal error” and nothing else.

Then I tried a Shipping configuration.

Got another error: “Could not find descriptor file ‘…/…/…/ProjectProtostar-Win32-Shipping/ProjectProtostar-Win32-Shipping.uproject’.”

I tried looking it up, tried messing with build settings, etc, to no avail.

THEN I got risky. I copied the .uproject that was found in the root of the game’s source code to the path the error said to. It got rid of the error, but I was greeted with another black screen, but this time with no error. I couldn’t tell if it was inside the Main Menu level (it has no sky, and nothing but a single building with a camera inside, and a level blueprint to spawn the menu) as no menu was spawned, and I couldn’t rotate or move the camera to see if the building was even there. I don’t know if it was the level I was seeing and that I spawned in the wrong spot, or it just couldn’t load it.

If anyone’s experienced a similar issue (minus the final black screen part, I’m guessing that has to do with the game not knowing where the .pak file containing all the assets are due to the .uproject not telling it, or something like that) and they’ve somehow fixed it, PLEASE let me know.

I am in UE4.9.2, using the Epic Games Launcher release. My project is full blueprint, and works just fine in the editor.

Hey TheShiftOSGuy,

  • Could you please tell me which version of the engine you’ve packaged in?
  • What platform are you packaging for?

Please look over the links that are listed under “[Failed to Open Descriptor File after Packaging][1]”. Please also attempt to package and run a UE4 template and let me know if the same happens to that project.

Looking forward to hearing back from you, thanks!

A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

same with 4.10.0

Engine Version 4.10.0
Packaging for Windows 64 and Windows 32. Same result

Trying a clean build of “Vehicle Advanced BP” works. :frowning:




I see that you’ve already resolved this by unchecking generate chunks. Let us know if you run into anymore complications.


Hey MagicTigger,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

Dear ,
many thanks.