Download

Upload option greyed out after cooking

The upload button is greyed out after cooking the mod. I have logged with my account on SteamCMD, and the modname.vdf in the ModConfig folder points to Epic Games\ARKDevKit\ModTools\Output\ModName

Have you filled out the name, description and I think it’s the update notes boxes?

To upload an item needs an image, title and some form of description.

There is a limit to the image size, and also some special characters in either the title or description will fail to upload.

-WM

I have filled Maps with the level name in exacts words, Title, description and an image in .jpg of 150x150 pixels, with output directory E:\Steam\steamapps\common\ARK\ShooterGame\Content\Mods.

Here for example, I made for testing a mod that just adds fibre item with a bigger stack size. Adding FibreIE with 10k max quantity to the master list. Then I cook the mod, and there’s just no upload option available.

Just to make sure, you did use browse and select the image. Just asking because in the screenshot there’s no image selected.

Yes, the image is just white(not that good of a choice now that you say that).

Your change notes are empty!

Filled changenotes, and still can’t upload.

I just noticed you filled the “Test mod output”. You need to empty that, then cook the mod again to be able to upload. If you fill this field, it will do a quicker cook(windows only) for local testing only and you wont be able to upload.

Then I still don’t know what’s the purpose of “Test mod outpu” but anyway, thank you, it worked.

That’s its purpose. It doesn’t seem to play nice though for some reason. Last time I tried using it the cooked files were completely haywire and nothing like they’re supposed to be.

-WM

I got it working with an additional manual step: It adds a new mod folder with the id 123456789 but this folder will only contain the modmeta.info and mod.info. However it also creates a new folder with the name of your original mod folder eg. if you mod folder in the devkit is “MyMod” there will be a MyMod folder in your games mod directory after cooking. In there you will find your actual cooked mod files. If you copy the contents to the 123456789 folder, you will be able to use the mod in the game by selecting the MODTEST mod.
Haven’t tried if anything changed with the latest devkit update.

where is the folder with id 123456789??