Download

Upload Limit from the ARK Dev Kit to The Steam Workshop?

So I recently spent tons of time learning how to use the Unreal Editor. (Having a blast) But have run into an issue with uploading that has left me at a stand still.

I was fiddling around for a long time trying to make it so that my map’s Materials and all were working correctly so I probably Cooked/Uploaded in steps easily 50+ times in the past few days.

Everything has been coming along really nicely until I textured my Sub Level, Then tried to Upload.

I’m not sure if it’s just coincidence that it was after painting it but maybe I’ve reached a limit for upload amount?

It compiled the Shaders and everything for the Sub Level but when I go to Upload it just stops.

I’ve watched the Processes while trying to upload and something called Steamerrorreport.exe momentarily pops up then goes away when I try.

Other than that, no log or anything I don’t think.

My map is titled ‘Persistent Level - WorkInProgress’ and in its current state you can walk right into the Sub Level that is just an Alpha Terrain.

Any help would be greatly appreciated. I just need to know for my sanity that I will be able to upload it somehow and that I didn’t break something when texturing the Sub Level.

I finally came across a solution to my own problem! But have another small question related.

The SOLUTION was to upload via SteamCMD:

NEW QUESTION* How do I change the preview Image when uploading via this method?

  1. C:\Steam\steamapps\common\ARKDevKit\ModTools\SteamCMD\Steamcmd.exe
  2. Login “username” “password”
  3. workshop_build_item C:\Steam\steamapps\common\ARKDevKit\ModTools\ModConfigs\ “MODNAME.vdf”

Thanks ~Q~ for the solution.

Well, correct me if I’m wrong. But isn’t your preview image location storred in a string within your Mod.vdf file? I would recomment to open that file with notepad++ to keep the right format!!! Be sure to JUST edit the path inside the quotation of the preview image path string.
Please tell me if that worked. Have a nice one!
PS.: If you open that file with something else what does not keep the right formating the file will get corrupt and the steamcmd throws an error!

You need to edit your MODNAME.vdf file ** Notepad works fine

“workshopitem”
{

"appid"		"346110 (I believe this is Arks app Id on steam)"
"contentfolder"		"<Path to the output folder of your mod>"

"previewfile"		"<Path to preview image>"

"visibility"		"<0|1|2> (Public|Friends|Hidden)"

"title"		"<Your mod name in workshop>"

"description" "<This can't be too long or the upload will fail>"

"changenote"		"<Add your change notes>"
"publishedfileid"		"<Enter your ModId When you know it>"

}

Thank you so much! :slight_smile: