Upgraded from 4.11 to 4.12, and project won't open

I just upgraded from 4.11 to 4.12. My old project has some blueprints that I would like to gain access too. Can’t really remember how I had implemented them.

Error messages are:

[2016.09.02-08.18.55:202][ 0]LogLinux:Warning: dlopen failed: /home/zerophase/Documents/unrealprojects/Dialogues/Binaries/Linux/libUE4Editor-Dialogues-494.so: symbol _ZN6AActor20NotifyActorOnClickedEv, version UE4 not defined in file libUE4Editor-Engine.so with link time reference
[2016.09.02-08.18.55:202][ 0]LogModuleManager:Warning: ModuleManager: Unable to load module ‘/home/zerophase/Documents/unrealprojects/Dialogues/Binaries/Linux/libUE4Editor-Dialogues-494.so’ because the file couldn’t be loaded by the OS.

I tried removing that file, and just ended up getting the same error, on libUE4Editor-Dialogues.so.

What are my options for upgrading the project?

Remove all old .so files, especially ones that have numbers in them (like -494.so in your example) - those were hot reloaded. Preferably, do not reuse the same directory for a new engine version.

Ok, I’ll give that a try. I’m guessing Linux doesn’t have all the features of Windows yet for upgrading projects?

Yes and no. On Windows you can also run into problems due to stale DLL files lying around.