Upgraded from 4.10 to 4.12: Spawned player character missing skeletal mesh in PIE

Just upgraded to 4.12 and everything is fine except when I PIE, the player character spawns but the skeletal mesh isn’t there. I still have control, minus the aim node.

I started my project with the sidescroller template in 4.8. I’ve changed it quite a bit to suit my purposes.
I spawn the spawn location and character BP from the MyGame BP.

I have local 2 player working and the child blueprint of myCharacter BP spawns just fine using the same methodology. But the first player is missing the skeletal mesh.

I don’t have a repro, but I can send my project over. I also tried upgrading from 4.10 to 4.11 and had the same results.

Whats really peculiar is that if I start the game in local two player mode, the child blueprint spawns without issue. Another peculiarity is that the thumbnails of both character blueprints in the content browser show both character meshes in each thumbnail. Not sure what the issue is. I’ve tried what I could find on the we to no avail. Can you guys help me out?


Solved this issue. I had to set the actor visibility in my spawn player events.