Upgrade 4.10.4 to 4.11.2 Gear VR build crashes

I have a project I’ve been using 4.10.4 to develop and I want to upgrade to 4.11

I right clicked my project file, switched engine version to 4.11.2
The project works just fine playing in editor but when I build to gear VR, the build works, it transfers just fine but when I run the project, as soon as I hook it up to my Gear VR I get an “Application has unexpectedly quit” and then it goes to the oculus menu.

The 4.10.4 version of the project worked just fine on the Gear VR.
I’m using a Galaxy S6 with Marshmallow.

I right clicked the project file, I went back to 4.10.4, repackaged the project and it worked just fine.

I made a copy of Epic Games\4.10\Engine\Build\Android\Java\assets
and I moved it into Epic Games\4.11\Engine\Build\Android\Java\assets

Same signature files, same folder name. Is there anything I could be overlooking?

Rather than right clicking the project file, I opened 4.11, opened the 4.10 project, created a copy and it worked OK.

There were a few bugs but at least the project didn’t crash on start up. Hopefully I can fix the issues and continue working in 4.11!

I hope my little mistake helps someone out there.