Download

Updated to UE4.25, now I'm crashing moving map-to-map?

Hello! I’m really excited to delve into using the latest version of the engine, but for the time being I’m running into an unfortunate issue.

Ordinarily I should be able to pass from map to map in-game without a hitch, but after updating I’m getting a crash. Here’s the report:

Assertion failed: IsInGameThread() || IsAsyncLoading() [File:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Engine/Private/Materials/MaterialInstance.cpp] [Line: 622]

Any advice is appreciated!

it has to do with the material on your terrain tile.

.25 and .25.1 have been corrupting maps like crazy.

I have had to replace tiles left and right as they cease to work and cause engine crashes after a while for really no good reason.

If you cannot open the map in editor, the only solution you have is just that. Delete and re-do.

Hmm, I don’t have any terrain tiles. I’m using vertex painting on static meshes.

I haven’t had any crashes in-editor yet, fortunately, but if my only option is to “delete and re-do,” then I’m afraid I’ll have to stick to UE4.24. That kind of loss would set me back months.

So, I really hope there’s something else to hope for here.

I’m having the exact same issue… same error while using open level node.

Any workaround or fix?

If anyone can share a level and the relevant assets it contains to be able to replicate the issue i’m sure a workaround or something can be found.

Usually errors like this are related to the conversion process missing something, or a reference not working.

I have treied porting 3 projects that use the open level system to .25 for imporvements, and none of them are having this particualr issue…

Even though it’s been over 5 months since this was posted, I wanted to reply because I was having the exact same problem just today and figured out a solution. I’m a total Unreal noob, so I don’t know if your problems had the same root cause as me. This is the error message I would get when trying to play the packaged build:
Screenshot (40).png
If I attempted to switch levels in the editor, Unreal would crash, and the crash log would give me a similar message. MostHostLA’s comment about the material gave me an idea, so I made a copy of my project and made a test level with almost nothing in it just to make sure it was actually something in the level itself and not a Blueprint I had done wrong. The test level opened up fine, so I knew it was a problematic asset somewhere in the original level. Since it was a copy project, I went into the original level and just started deleting things, testing the level-switching each time. I finally found the offending asset that was causing the problem.

It was a text render object. After I deleted that, the level loaded up fine, so I created a replacement asset using a plane and a transparent material (which was good enough for my purposes.) I’m guessing the problem was caused by something from the engine content related to the text render object not loading correctly. Everything involving in-world text has been giving me a headache.

Like I said, I’m new at game development and I’m doing it as a hobby, so I don’t fully understand what’s going on and I can’t guarantee it will work if you try it. But my advice would be to (after backing up your project) start by removing text render objects, and if that doesn’t work, just systematically get rid of stuff until your level loads. It’s low tech and brute force, but it worked for me.