(updated after tests) Radial Damage is not applied when Line trace hits a brush... :/

Been running a few test after still not beeing able to figure out why this is happening and it seems like the Damage is not applied when hitting a brush, although when hitting any other Object…

I am so clueless…

Hey guys, for some reason the damage is only applied when I shoot a chair or a table for example (I can tell because when my character stands next to it he gets damage) but as soon as I shoot the ground or a wall it doesn’t apply any damage anymore (the string is printed that says no actor hit and my char doesn’t get any damage) been trying to solve this for ages now by creating a damage blueprint casting it to that etc. just can’t figure out the problem… PLEASE HELP ME

Thanks in adcance,

Are you sure that you are spawning the damage sphere at the right location?

Hmm I have actually not worked with a damage sphere before… worked well in another blueprint without it… i’ll have a look and see if it works :slight_smile:

Oh wait it can’t actually rely on the damage sphere as it works when hitting props but not when hitting meshes… so it has to be another mistake :confused:

If this helps you guys figuring out what’s happening here some screenshots from my ingame tests:

I made it so a message is printed if no actor was applied damage to and none if there was an actor that got damaged…

the first one shows the actor recieving damage and the secon one not (its a brush)