Update to UE5.1 have anim layer bug

when i update to UE5.1 , when I use Anim layer it will use self layer default like :

you know my anim layer interface is wrote in other BP like Anim layer Base to implement Logic , and use layer interface in main anim BP , but in 5.1 something will be wrong, in that PNG you can find Anim Layer (Self) ,I drop anim layer interface to my graph in main anim BP , but it 's Anim Layer (Self) and can’t change , so it will never work because the logic is in Anim Layer Base BP


I have same issue :frowning: hope to fix this asap…

I have a temp fix , copy old node and you can change to you new layer in editor bar :joy:


Yes. I just solved it with exactly same solution. I just made animbp and layer interface at 5.0 and migrate it to 5.1 project and mount skeleton that i want. Copying old note works well haha


For more detailed information, making anim layer interface and implement it in 5.1, and if you try link anim layer class, it make anim instance correctly, but in debug view, linked anim layer node is not activated. I was trying get linked anim layer instance with tag, debug message tells linked animBP correctly, but animation doesn’t work. I wish Epic could hotfix it soon.

There is no “Add” button next to Implemented Interfaces in 5.1.0. If you press Add, it will add the Anim Layer Interface as Inherited Interface, not as Implemented Interface.
It was working before in 5.0.3.

Steps to Reproduce:

  1. Create Anim Layer Interface.
  2. Create Anim Blueprint.
  3. Go to the Anim Blueprint class settings.
  4. Try to implement Anim Layer Interface by adding it.
  5. It will be added as Inherited Interface, then it will cause issues later on when you try to call the Animation Layers.

I hope we get a hotfix soon!


This topic has been moved from International to Programming & Scripting: Blueprint.

When posting, please review the categories to ensure your topic is posted in the most relevant space. Hopefully, this new category helps you to get the answer you need!

Goodluck and happy developing :slight_smile:

1 Like

5.1.0 (Bug)

5.0.3 (This is how it should be and how it used to work, unless if something changed in UE that I am not aware of)


I try to add the “Link Anim Class Layers” function to B_Hero_ShooterMannequin>Construction Script in Lyra Project(UE5.1).
I got an error “Skeletal Mesh Component Object Reference is not compatible with Anim Instance Object Reference”.

This node needs to be moved to the Event Graph, so we cannot add this node inside Construction Script.

1 Like

hi , you need use Link Anim Class Layers in begin play event

1 Like

Same problem. This is serious. Currently Animation Layer Interfaces are unusable because of this. Hope this will be fixed fast.

1 Like

I’m having the same issue. And in one of my 2 animbps, it won’t actually let me change the layer under Details > Settings. Luckily I have 2 animbps and I could copy an old node over from one and paste into the other…

Did you found any solution to this issue? I’m just a newbie in this, trying to complete one of the tutorials, and now I’m stuck.

1 Like

I have a temp fix , copy old node and you can change to you new layer in editor bar

I noticed this bug report has been tagged resolved. But it is temporarily fix as workaround. I hope it’s fixed in github project asap. I’d like somebody can remove ‘resolved’ tag in this report too until official fix will be done.

I have the same issue. But I’m not able to temp fix because I also had errors in building a game project using UE5.03 to get old node. FYI, steamdeck.automation.dll load issue. Please fix the anim layer bug asap on UE5.1 because I’m stuck.

Just wanted to chime in and say that the workaround mentioned in this thread (copying the old node from a 5.0 project) is potentially dangerous. I did it, it worked during that session, but after closing, my project kept crashing immediately upon opening due to an anim graph compiler issue. For now, I’m switching my project back to 5.03

Thanks for solving my problem

1 Like

For reference, this issue is due to be fixed in 5.1.1. Public issue trackers: