Update to 4.10.2 "prerequisites" error code R-1638

Everything was going well until I decided to updated from 4.10 to 4.10.2 through the launcher. Ever since then, I have not been able to get a fully successful install and now I cannot even regress back to 4.10.0 or 4.10.1 as they are no longer present on the list.

NOTE: UE 4.9.2 still works without any issues.

The first issue was related to drive space. I followed the instructions that epic listed on how to copy and create links to my launcher data. That freed up tons of space and I was able to continue further through the installation process until I hit another snag.
The error message I receive is related to the “prerequisites” error code R-1638. After digging through some of the posts related to this problem, I followed various instructions that included: uninstall Windows Visual Studio 2015 and redistribution x64 and x32; uninstalled and reinstalled ue4 4.10. I still have not reinstalled VS 2015 as yet.

At the present time, these did not work. I verified that I do have the latest windows 7 64bit updates.

Any recommendations? Did I miss anything?

I read another post that recommended installing the prerequisites manually located at C:\Program Files\Epic Games\4.10\Engine\Extras\Redist\en-us. I ran this installation and then resumed the installation process via the Launcher. After verification, it stated that it was installing the prerequisites but failed once again with error code R-1638… frustrating!

Here are parts of the end of the Launcher log after the Resume failed:

‘…/…/…/Engine/Plugins/Messaging/MessagingDebugger/Content/icon_invisible_16x.png’ error.
[2016.01.21-15.06.12:959][ 0]LogSlateD3D: Could not find file for Slate resource: …/…/…/Engine/Plugins/Messaging/MessagingDebugger/Content/icon_invisible_16x.png
[2016.01.21-15.06.12:965][ 0]Portal: Constructing App Data Access Layer
[2016.01.21-15.06.12:975][ 0]LogSelfUpdateService: Initialising for EpicGamesLauncher 2.8.3-2819560+++depot+UE4-LauncherLive-Windows.
[2016.01.21-15.06.12:975][ 0]LogSelfUpdateService: Requesting launcher build info.
[2016.01.21-15.06.12:975][ 0]LogSelfUpdateService: Deprecation updated. Deprecated:0.
[2016.01.21-15.06.12:985][ 0]Portal: Constructing App Domain Layer
[2016.01.21-15.06.12:985][ 0]FCommunityPortalOSSImpl::InitialiseOSS
[2016.01.21-15.06.12:986][ 0]LogSelfUpdateService: Deprecation updated. Deprecated:0.
[2016.01.21-15.06.12:987][ 0]FCommunityPortalDynamicContent::HandleEMSFileUpdated()
[2016.01.21-15.06.13:063][ 0]LogSelfUpdateService: Local manifest loaded 1.
[2016.01.21-15.06.13:063][ 0]Portal: Constructing App Presentation Layer
[2016.01.21-15.06.13:131][ 0]Portal: Constructing App UI Layer
[2016.01.21-15.06.13:132][ 0]Url Processing Complete: /sign-in → /sign-in
[2016.01.21-15.06.13:132][ 0]Navigating to Internal Url: /sign-in
[2016.01.21-15.06.13:135][ 0]Navigating to Unknown Internal Url Failed: /sign-in
[2016.01.21-15.06.21:973][ 0]LogExit: Preparing to exit.
[2016.01.21-15.06.21:973][ 0]BuildDataGenerator: FATAL ERROR: EBuildPatchInstallError::ApplicationClosing,

link text

Here is the Launcher Log file with debugg activated:link text

anyone? please?

Should I just uninstall everything including the launcher and start from scratch? If so, will some files be left over?

5 days and no help. Prett sad. I Had better service when I was paying for Unreal.
I’ll give it one last full uninstall and reinstall.

Hello Haskellf,

I apologize for the delayed response. Do you currently have the 4.11 preview build installed on your system?

Hey, if you’re still having this issue I figured it out. I tried uninstalling the redists and prereqs, updated my windows version and even uninstalled the engine and stuff and still couldn’t figure out what was wrong. If you have the 4.11 previews set up and are getting the R-1638 issue you’re going to have to go into the 4.11 folders and navigate to C:\Program Files (x86)\Epic Games\4.11\Engine\Extras\Redist (unless you saved it somewhere else) and uninstall your prerequisites. Then go and re-install your prerequisites in my 4.10 folder located: C:\Program Files (x86)\Epic Games\4.10\Engine\Extras\Redist\en-us (unless you have a specific install location) and re-downloaded the engine version from my launcher and everything worked.


We have recently updated the launcher to address some of the prerequisite issues. Please see the accepted answer to this post for the steps to follow.

If this does not resolve the issue, please post back and keep us updated.

I uninstalled and reinstalled the launcher and now it works fine. -thanks!