Update beam noise range from blueprint


I am trying to update my beam emitter by having a noise range constantly update by a random variable (resulting a sudden big/small lightning effect). However, I could not make it work, even I searched and references the similar problem on the forum or tutorials.

First of all, this is the end product that I hoped:

As I understand that in order to be able to make changes outside the cascade (to the blueprint), I must change the distribution to Distribution Vector Particle Parameter.

As because I changed the distribution, I also exposed the parameter as shown:

Finally, this is my level blueprint:

When I run the game, sadly, the beam does not create noise and it remains a straight line like this.


Do I missed anything or done anything wrong? Or perhaps, are there any suggestion? Thanks.

I stumbled on this question about a year after it posted, and eventually found the solution. For those that are wondering on how to set random beam noise via blueprints, here’s the answer:

You first need to setup the noise range as a Distribution Vector Particle Parameter. You will also need to make certain that:

  • Your Min Input/Outputs are the lowest values that you would ever use
  • Your Max Input/Outputs are your highest values that you would ever use

^ That is the solution for the question that is posted. Below is an example of my setup


As for how to modify it via blueprint, I created an array variable that’s exposed where I can modify the min/max values for the beam noise whenever I wanted. Then, on a per-Event Tick basis, I pick a random float in that range and I apply it to the parameter

And that’s all there is to it!