Download

Unusual Problem Regarding Creating BSP Geometry

Hello. Last summer I started working on a project in Unreal Engine 4.25. I had no problems creating levels in that version of Unreal Engine, everything worked fine. I left that project for a while and I returned last week, upgrading to Unreal Engine 4.26.1. Everything was fine as I started working on a level but there was a problem that occured last night. I use the BSP geometry feature to make my levels and this has always worked fine for me, I’m not sure if this is how it’s supposed to do but I’m just making this for fun. What occured though is I would move the cube, for example, and it would hang the engine for a few seconds and then every other piece of BSP geometry would flash. This makes creating maps extremely hard and quite frankly annoying. The same problem occurs when I select a face, corner or edge and try moving it. I’ve tried a few things to fix it. I’ve verified the integrity of UE4 its self, which didn’t solve the problem. I also tried making my levels with realtime off which did not fix the problem either. I am aware of the ability to modifiy the settings to allow me to move the geometry not in real time and build it but this is more impractical than the problem I currently have. I have tried in unlit, I’ve tried deleting geometry, incase I had too much despite not having a lot in the first place and it did not help. I tried removing foliage, sky sphere, lights, and anything that could have an affect. I’m not sure where to go from this other than just downgrade and see if the problem still occurs on other verisons, but before I do that I would like to try everything I can to make it work on this version.

Also, oddly, sometimes it’ll lag and my camera will be sent very far away.

Click here to see a video of me trying to recreate the problem (which doesn’t appear to be very hard to recreate).

My specs:
Processor
Intel(R) Core™ i5-6600 CPU @ 3.30GHz
Video Card
NVIDIA GeForce GTX 1060 6GB
Video Card #2
Intel(R) HD Graphics 530
RAM
16 GB
Operating System
Windows 10