Unsupported graphic card error when launching

When I try to launch the Epic Games launcher I get a graphic card error, look below:


I have tried reinstalling but that didn’t work, I also tried looking online for this problem but I have not been able to find how to fix it or I failed to understand how to fix it. Personally I have very little knowledge of fixing problems like this.
I did not change anything since I last launched it and it worked regarding launcher settings or settings on my laptop. I did not experience any problems until now.
If anyone knows how to fix this problem that would be great.

I tried adding my DxDiag file but failed to do so because it doesn’t let me.

So today I tried launching a different game and got this:


So I’m guessing this is the same problem with the epic games launcher, now according to the DxDiag file my DirectX Version is DirectX 12. Anyone who knows if this is related or not?


Which graphic board do you have?

Could you please take a screenshot of the Nvidia Control Panel? Right click in an empty space in the desktop

I have a “Intel(R) HD Graphics 530” if I’m correct.

Edit: Believe I might have two if that’s possible?
GPU0: Intel(R) HD Graphics 530

Sorry for it being in Dutch but failing to change that to English, I opened the systeminformation screen after opening the Nvidia Control Panel

Check this…

Seems you have to reinstall windows :frowning:

It seems to be the same problem I have, tried running multiple other games now all giving me graphic card errors.
Will do the reinstall and see how it goes and let you know, thanks for the help so far :slight_smile:

Going to do it in the weekend since It’s late now for me and I’m too tired to do this properly right now.

Seems like I have been able to fix the problem without having to reinstall windows. Using device mannager I forced my NVIDIA GeForce GTX 960M to update and since it has worked. But thanks for the help anyhow :slight_smile:

How did you force your graphics card to update ?

Using device manager I could update my graphic cards, after trying multiple times they finally did and fixed the problem, keep in mind I did this on windows 10

I had the same error after windows updated, and reinstalling the graphics drivers sorted it.