Unresolved external symbol, static library (Alembic)

I’m slowly losing my sanity trying to make Alembic work with Unreal Engine 4 (two layers of hell juxtaposed on top of each other). My endgoal is to access Alembic library from a UE4 project’s code.

First step was compiling Alembic for Windows, which was a great pain to begin with. I finally managed to do it by creating an empty VS project, putting all of Alembic files in it, putting the right paths for all includes and libraries prerequisites and compiling it all, which gave me multiple .lib.

Now, the step I’m struggling with, managing to link it with UE4. I put this into Myproject.Build.cs :



So there’s basically the includes for Alembic and a few includes he couldn’t resolve from dependancies for Alembic. There’s also one of my compiled Alembic libraries, the one I want to try right now.

Now, in my VS2012 project properties, I have set up all the needed paths for includes and libraries. However, when I try to build my project, I get a massive log of errors, most looking like this :

1>AlembicAbcCoreHDF5.lib(CprData.obj) : error LNK2001: unresolved external symbol "public: virtual __cdecl Alembic::AbcCoreAbstract::v7::ScalarPropertyReader::~ScalarPropertyReader(void)" (??1ScalarPropertyReader@v7@AbcCoreAbstract@Alembic@@UEAA@XZ)

or this :

1>AlembicAbcCoreHDF5.lib(DataTypeRegistry.obj) : error LNK2001: unresolved external symbol H5T_STD_I16LE_g

I don’t even know if this is a problem linked to UE4 or just in general, and I can’t seem to find a solution. I feel like I tried everything, any idea or hint ? I also tried using the Alembic compiled library packed with Maya, but it results in the same error messages (in addition to problems with VS version, because it has been compiled with 2010 and I’m using 2013).

Thanks in advance !

1 Like