Download

Unresolved external error that won't go away.

Originally, I had created two classes in my module, not counting the module class itself. One class has the header of the other included. In this class I have a variable which is an array of instances of the other class. Originally both were AActors, but after changing them to UObjects and the spawn to new, I still get the same error.

In my UControllerManager’s Initialize() function

Controllers* = NewObject<USixenseController>();

This gives the error:

error LNK2019: unresolved external symbol “private: static class UClass * __cdecl USixenseController::GetPrivateStaticClass(wchar_t const *)” (?GetPrivateStaticClass@USixenseController@@CAPEAVUClass@@PEB_W@Z) referenced in function “public: void __cdecl UControllerManager::Initialize(void)” (?Initialize@UControllerManager@@QEAAXXZ)

This is, if I am reading it correctly, cause by GetPrivateStaticClass which is getting called somewhere deep in a UObject that is being instanced. I have no Idea why. I haven’t found anything in the docs or answerhub that helps.

I found some links that may be relevant in case anyone lands here from a search. Linking error when exporting component - UE4 AnswerHub
Using NewObject With USplineComponent, Compiler Linker Error, USplineComponent::GetPrivateStaticClass - UE4 AnswerHub
LNK2019 GetPrivateStaticClass error on my own class? - UE4 AnswerHub

I’m trying these solutions now.