Download

UnrealPak.exe fails

Hello everyone, I’ve downloaded the zip file of Unreal Engine 4.12 from git hub.
I extracted it and compiled Development Editor | win 64, Development | Android, Shipping | Android.

Everytime I package the game, this problem shows up and when I press ok, the packaging fails.
I can’t find any solutions concerning with it.

What should I do to make UnrealPak.exe work properly? Please help me.

Screenshot (133).png

Can you manually run the pak tool?

-Edit-
A
workaround could be to not pack the files into the pak, Do you have to do this for Android?

Thank you very much for your reply. I don’t really understand what does “pack the files into the pak”. Can you pls explain it to me or share a link that says about pak?

Or what can I do to make that UnrealPak.exe fail error?

It puts all the content into a single archive stead of having lots of files.

Have you got the .Net framework installed, I think it is version 4 ?

Can you find and double click on the “unreakpak.exe” file in the engines binaries folder?

HTH

Thank you for your reply. I’ve installed UE 4.9 in another directory and can open UnrealPak.exe correctly. But when I opened UnrealPak.exe in my 4.12 binaries/win 64 folder, it fails.
3e566f0a72d3cb7a36f928cdb95ad353401cb95e.png

Before that unrealpak.exe fail error appear, an error about “missing api-ms-win-crt-convert-l1-1-0.dll” error appears. So I downloaded that dll and put it in binaries/ win 64 folder.
The dll error no longer appears and the UEPak error appears.

I have also installed 4.9 in another directory is there a way to copy some files from that 4.9 directory and replace them into 4.12 directory to solve that UEPak error?
Thanks.

that is the LAST thing you want to do, Downloading random runtime DLL’s from the internet.
That looks like it might be from the VC++ 2015 runtime.

Check this if you want for info about that DLL.

That is something you DON’T want to do without knowing exactly what you are doing, It’s like open heart surgery.

It looks like you just had a runtime that failed to install, Are you using Win10?

HTH

-Edit-
Forgive me if I come off sounding a bit harsh, But downloading random DLL’s from the internet (even if you know which one) is dangerous as they could be altered or rely on other components that were supposed to come with them.

thank you very much. I failed to install vc_reddist 2015. I’m using windows 8.1.

Your welcome :slight_smile:

So, Is the problem solved?
That should have been installed along with VS2015, Did you use the default installation options?
The default installation options do not include C++.

The problem is not solved yet. Does “UEPak” fails means that because I haven’t installed VC Reddist 2015 properly? I can’t install VC Reddist 2015 because my window 8.1 needs to be updated. If VC Reddist 2015 will solve my problem, I’ll update my window and install VC Reddist 2015. Thanks

What version of the .Net framework if UEPak built for?
Maybe setting it to use .Net 4 will work, Do you have UE 4.11 to try that version of the pak tool?

Is that what the VC++ installer says?
Did you use the x64 version?

Thanks for your help. I’ve updated my windows 8.1 and installed VC_redist 2015. Now the UnrealPak.exe error no longer shows and android was succeeded to build.

Tha’s good!
I wonder what was the cause for the VC++ redist failure, It’s a bit late now; But I think the installer creates a log.