Download

UnrealFastNoise - Modular Noise Generator Plugin

Thanks, I’ll get that change pushed to the repo later today.

@zerofiftyone Thank you very much.

Here is a small update as well. :slight_smile:

UE4Editor_2017-06-20_14-36-13.png

Looks cool!

I released the game I was using this plugin for recently by the way: https://zerofiftyone.itch.io/evader

https://www.youtube.com/watch?v=bZjy6rFM7-Q

That looks good!

Hey,

This plugin looks awesome - however, I am running into some issues.
I found your tutorial series on youtube and got through parts 1 and 2, the issue arises in part 3.
I am duplicating everything you have in part 3, values and all - but the results I get look nothing like what you have.

I am using 4.16.1, got all three required plugins, BUT for the RealtimeMeshComponent - I am using the plugin found on the UE4 marketplace.
EDIT: tried it in 4.15.3 get the same results.

The attached image is from 4.15.3 - well if I can get the image attached…CashGenIssueImage1.jpg

In case it is to hard to read the values they are:
Noise Type: Value
Seed: 12345
Frequency: 0.00001
Fractal Gain 0.5
Interpolation: Linear
Fractal Type: Rigid Multi
Octaves: 6
Lacunarity: 1.7

Thanks

Hmm, should be exactly the same if you’re using the same settings. I am due to make a new tutorial video because I’ve pushed a bunch of changes that mean setup is a bit different now.

Hi there - plugin looks really grat :slight_smile:
any news of 4.18 version ? - and the tutorial?

Spent some time yesterday trying to set up a new demo project but ran into some version problems, and had to give up in the end.

I’ll give it a try again when 4.18.1 is out.

Updated to 4.18 and changed to IWYN, tested packaging etc.

Created a separate demo project repo:

Working on updating to use the SIMD enhanced version of fastnoise.

Should give a 4-5x performance uplift.

Hey @**mid_gen **great work!
But one question regarding cellular noise, can I get edges of centriods like in Voronoi diagram? Or its just calculate result for XY(Z) point based on chosen algrorithm?
Thanks!

Deleted my previous posts prematurely - I managed to fix the issue with the plugin not working as an Engine plugin (just compiled as a project plugin then moved the binaries over), however, that did not fix the problem with the plugin working only in editor and not in the packaged game.

Here’s the error:

LogStreaming: Error: Couldn’t find file for package /Script/UnrealFastNoisePlugin requested by async loading code. NameToLoad: /Script/UnrealFastNoisePlugin

And as previously mentioned, if I change the setting from Developer to Runtime, I get an error on compile:

LINK : fatal error LNK1181: cannot open input file ‘C:\Unreal Engine\UE_4.18\Engine\Plugins\UnrealFastNoisePlugin\Binaries\Win64\UE4-UnrealFastNoisePlugin.lib’

In your project’s Build.cs file, make sure you include “UnrealFastNoisePlugin” in your PublicDependencyModules.

My demo repo is tested and working on 4.18.1 packaged builds, you can check it for configuration.

Welp, that was an easy fix! All working.

Extremely appreciate the help. Still learning my way around c++ so didn’t even think to check.

It seems like the UnrealFastNoise still doesn’t work in UE4.18,
I copy the plugin into"C:\Program Files\Epic Games\UE_4.18\Engine\Plugins\Runtime"
but
it turn out to say" missing or incomplete in current engine version…how to fix it??

I download this demo but all this plugins files are empty, and so does in github…very confused now…and the UnrealFastNoise does’t fit the UE4.18…

wow!! how you make this! By using the c++ or BluePrint?? Could you share the method about creating a this amazing sphere?

The plugins in the demo project are git submodules, you’ll need to pull them all.

In TortoiseGit (my Git client of choice) it’s as simple as ticking the ‘recursive’ checkbox when cloning.

or


git.exe submodule update --init --recursive

Should do the trick


fatal: reference is not a tree: 86af3585a9c0e97859c7c6dabd710f2f3a16430e
Unable to checkout '86af3585a9c0e97859c7c6dabd710f2f3a16430e' in submodule path 'Plugins/RuntimeMeshComponent'


i can download the git project by hand and copy it. but --recursive won’t let me download it :frowning:

I’m trying to build the plugin on my Mac, but Xcode is giving me “Inline function UFastNoise::GetNoise2D is not defined”, same for GetNoise3D.