Download

UnrealEngineLauncher slows the editor down.

I noticed that UnrealEngineLauncher slows the editor’s FPS from ~37 FPS to ~17 FPS on my MacBook. (UE4 4.2.1-release i5 MacBookPro 16gb ram)

But the Editor constantly re-opens the Launcher. I like the marketplace in the launcher, but if it has this big of an impact on FPS, I don’t want it running unless I specifically open it. So I made this patch if anyone else doesn’t like UE4 opening up the Launcher after they close it.

https://github.com/robert-wallis/UnrealEngine/commit/95f2d511898dd1c019ddf597515432da0d175abf

P.S. Those are the FPS rates with all windows closed, including the toolbar, except the OutputLog so I can read the hitches.

It would be nice to have an option in the editor preferences to disable the launcher.

Nice job!

Hi smilingrob,

Can you please make a post on the answerhub at http://answers.unrealengine.com so we can assist you? Thank you!

I’ll append to two answers, one for the low perf, and one for disabling the Launcher.

Since those questions already exist.

We made a launcher app with Slate, and it shows the same problem… using 16% of CPU time on a beefy rig. Heading into StandaloneRenderer (which is the same renderer the Epic Launcher uses) and forcing vsync to be enabled has lowered CPU by 15.8% to 0.2%.