UnrealBuildTool taking too long to run

Running UE4.15 on Windows 10 Trying to package a C++ project. Not sure if this is a permissions issue? New to this, any Ideas? Attached error log. Thanks.link text

Build is what is used to build the lighting and paths in your level. Are you referring to the packaging of a project or the build button cause they’re two different things.

Thanks for your response…Packaging C++ Getting this error: LogUObjectGlobals:Warning: Failed to find object 'Class None.

Created a C++ class none for it and got further errors:
LogUObjectGlobals:Warning: Failed to find object ‘Class None.’
PackagingResults:Error: Error Unknown Error
Warning: HotReload operation took 9.3s.
LogVSAccessor:Warning: Couldn’t goto line number ‘0’ in ‘C:/Users/Buck/Documents/UnrealProjects/MYTEST9/Source/MYTEST9/MyClass9.h’
LogVSAccessor:Warning: Couldn’t goto line number ‘0’ in ‘C:/Users/Buck/Documents/UnrealProjects/MYTEST9/Source/MYTEST9/MyClass9.cpp’
PackagingResults:Error: Error Unknown Error

Hello bletherboy,

The following messages are only warnings and shouldn’t be blocking anything from compiling at the moment:

LogUObjectGlobals:Warning: Failed to find object 'Class None.'

LogVSAccessor:Warning: Couldn't goto line number '0' in 'C:/Users/Buck/Documents/UnrealProjects/MYTEST9/Source/MYTEST9/MyClass9.h' LogVSAccessor:Warning: Couldn't goto line number '0' in 'C:/Users/Buck/Documents/UnrealProjects/MYTEST9/Source/MYTEST9/MyClass9.cpp'

Then you have the next message, which is:

PackagingResults:Error: Error Unknown Error

This basically means that there is an actual error message elsewhere in the log and can often be found by using ctrl+f to find the word “Error” in your log. By doing that with your log, I see a couple things. The first is:

[2017.02.22-08.21.42:081][906]UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: clang++.exe: error: clang frontend command failed with exit code 3 (use -v to see invocation)

which is following an assertion failed message. As it looks like these messages are coming up around android SDK files, it seems like there could be something either out of date or corrupt with your SDK installation. I would suggest reinstalling the Android SDK.

There also seem to be some iOS provisioning issues but that should only matter if you’re packaging for iOS, while it looks like you’re attempting to package for Android.

Hi Matthew,

Thanks for your response. I assumed it was an issue with the SDK. I was running Android 1R5. I have been seeing that 1R4u1 should work better. However I am having issues with the installation: Installing Compile Samples 4.0 failed. The compile log says it can’t find C:\jdk1.8.0_77. I have jdk1.7.0_71. Now I am waiting on a fix. UE is currently not recognising android SDK as installed correctly. I have had a few issues with SDK failures. I wasn’t sure if it is a permissions issue. I have been running everything as administrator Windows 10

I’ve never seen that issue before but that would be an issue involving the Android SDK rather than the editor itself. I suggest uninstalling the SDK entirely, rebooting your computer and then attempting to install the new SDK. If you continue to have issues installing the SDK, I would suggest searching for information on the error you’re receiving to see if there may be instances of other users running into this issue.

Hi Bletherboy,

Not sure if this helps but i kinda ran into similar issues while i was configuring my android dev env.

While the installer extracts the contents of the sdk platform it first extracts the folders with the standard android sdk naming convention and then renames it with the naming convention. (Highlighted in the img below)


This is where it got funky and i ended up with the following folder structure: “/…/platforms/android-19/android-4.4.2/”

All i had to do was move all my files from “/…/platforms/android-19/android-4.4.2/” to “/…/platforms/android-19/”

(you can delete that leftover residual folder “android-4.4.2” if you’d like).

No issues post that. :slight_smile:

Thanks, That is something I will try. First I need to uninstall everything and start again. Thing’s are looking real messy! I’ll update this post if I have any success.

Ok, so I had success in packaging the files. I uninstalled everything and stated again, using my empty D:/ So I could keep a clearer eye on what had installed. When I had issues with Codeworks that failed on certain installs, I ran the android.bat file as admin and manually installed all the fails. This worked!..Unfortunately I have another issue when trying to depoly to Samsung Galaxy S7 Edge.I think it is due to file paths not being recognised, as I used my D:/ for the SDK? I used ETC1 for output. Maybe I need ETC2? All developer options are enabled and my OSIG Identifier is in the right place on my C:/ I have attached the error file.

Thankslink text

Hello bletherboy,

I apologize for the delay, it may be due to the SDK being on your D:/ drive as you suggested. I’m not completely sure if it’s the same way with the Android SDK but I do know that other SDKs that Visual Studio has to interact with can have problems when placed on other drives than the primary.