Download

UnrealBuildTool Failed to compile.

Did anybody seen this error before ?

56af8142834ccef21ae334aaa92d6142e403d1f7.png

I tried re installing Visual Studio, and running vsrvars.bat but without any success.

I tried redownloading source code and rebuilding.

Anybody knows how to fix this issue. i know its not related to unreal engine it self but i tought i might ask here. :slight_smile:

Thanks a Bunch :smiley:

Found the fix for this issue.

6ac5d1d176e9db29617d0738f8044b3f731caf93.png

For some weird reason it was missing the System Variable.

Hello, Can you explain a bit about what you mean and how you fixed this problem please? I had everything installed great for a long time but when it stopped working, I forgot how I got Visual Studio working and ‘linked’ with unreal! PLEASE can you tell me is there an easy process or steps to get back to ‘building’, I just want to develop games not deal with Microsoft (which I do, fight these sorts of things 90% of the time and 10% time animating characters, and doing FX…,) When 2019 refuses to ‘generate project files’ and 2017 no longer seems even available, ??? I am suddenly so lost! If only this awful infectiont at calls itself ‘Incredibuild’ would stop trying to get money from me and extricate themselves from my Projects., so I would not have to fight with Visual Studio year after year, Incredibuild is the stem of all my problems for years,. This too,…

Any help, so very welcome!

UPDATE: I uninstalled the: 'Visual Studio Team Explorer 2017 (version 15.9) and when it was done, the Familiar Visual Studio 2017 Installer multi package option came up, I found Unreal using the search box ( hope that means the ‘dependencies’ that will ‘link’ this to Unreal) etc and for the first time I am leaving Incredibuild unchecked! I think I read that it need C++ checked,. ( I hope it’s not C# That’s Unity right?) so I will look for that, and Android too for Oculus Quest stuff…

Now things seem more familiar again! Whew :slight_smile: I thought I would leave this breadcrumb of a clue of what worked for me :slight_smile: