UnrealAndroidFileTool.exe "Did not find a bind listener"

In the new Unreal Engine 5.0 Preview 2 the new UnrealAndroidFileTool was added to the install process for Android APKs, but I run into issues where on install, it hangs unable to connect to the device and then returns the error “Did not find a bind listener”. The device is there and I’m able to connect without issue, this seems to be an issue of the new tool.

I have had success before, every so often it connects and installs properly, but most of the time it fails.

Has anyone else run into this issue? Has anyone found a consistent way to install without this problem or to circumvent it or knows what is even causing it?

Wanted to update with my current work around, which is to delete the existing output files and repackage my project. If I repackage the files without deleting the old ones it hangs during installation.

im getting same issue. Can you elaborate what you did to fix? I’m a newbie and not really super knowledgeable in programing but I can bare it sometimes lol. Had a bunch of issues to get my project to even build and sdk issues and finally got to this point.

The only way around it I’ve found is to delete the output folder and repackage it.

I’ve figured out a more definitive solution to this issue. It seems that the RM commands earlier in the bat file don’t actually do their jobs. Mine was the file at /sdcard/Android/obb/ and then the name of the project (it’ll be com.companyname.projectname). Just delete that and run the bat file again. If it doesn’t work the first time, try it again and it has worked for me.

I ran into the same thing trying to install to the Lume Pad. I should add that I tried the solutions above. The device is connecting just fine but I get the same error when it goes to start the server:
D:\UE5-build\Android_Multi>.\win-x64\UnrealAndroidFileTool.exe -p com.YourCompany.MyProject19 -k 98364449477BFF0D1CB586A788C47DA0 push main.1.com.YourCompany.MyProject19.obb “^mainobb”
Trying to start file server com.YourCompany.MyProject19
Did not find a bind listener
ERROR: Unable to connect to 2FF001000001287

D:\UE5-build\Android_Multi>if “1” NEQ “0” goto Error

There was an error installing the game or the obb file. Look above for more info.

Hey, struggling through same issue, did anyone manage to fix/find a workaround?

did you use a sd card? i dont have one right now and cmd says this

/sdcard/Download/obb/com.Company.generator: No such file or directory
Installing new data. Failures here indicate storage problems (missing SD card or bad permissions) and are fatal.

I’m using the install .bat file of a packaged build to install my game to Meta Quest 2 and had the same problem. I don’t know if that’s just a specific case but to anyone it may help:

  • Had the device connected and also ready to use
  • Ran the bat file and waited till the UnrealAndroidFileTool.exe part. (Installing new data…)
  • When it reached to that point, I activated the device and tried to open the new installed app
  • UnrealAndroidFileTool worked and installed the obb file!

I’m not sure how and why it didn’t work without doing this but I tried a few times and that seemed the only way.