Download

Unreal4 is not reading android connection

Hey everyone, I am new to the mobile side of development, and I hit a few snags when it comes to getting runtimes and builds to run on my phone.

I am using a Samsung Galaxy S3, running Android 4.4.2

I went through the totorial on the documentation website, it did not works, I called a friend over and we tried a lot of things, installing a samsung driver he had, and we finally got it to register on the CMD ‘adb devices’ command line.

blah.png

We wend over to unreal 4 and checked the launch and it worked! there were orientation problems so we went to the android project settings under platforms and he changed a few things. In the SDK config, under android SDK, we pasted all the URL options to the proper paths:

This is the proper thing to do, yes?

Also, under android in the same drop down, he changed a few things here as well:

bcb8b697c177b89d44ad1c5d57d355c9ce44e091.png

We changed the orientation to portrait, and he told me to change the SDK version to 19.

It doesn’t work anymore. Even though it still registeres in the CMD when I type in ‘adb devices’

Did I so something wrong in the android project settings? I attempted to put the values back to normal but it still didn’t work, did I miss something?

I’d appreciate it if anyone knew the answers and shared it with me!

~StevenWaltherMedia

Another thing I want to add, is when I attempt to bake it out to the phone, or hit android support under the launch drop down, it gives me this:

1bcd06ab817bf201c7e7977f8c620bbf8e216688.jpeg

The URL redirects me to the android quick start, which I already went through. This also did NOT show up when it worked for the first time! DId some installed files suddenly revert? Is my driver gone now? I have no idea what is going on!

Hi StevenWaltherMedia,

I’m not entirely clear on what is the problem you’re seeing. What part is not working? Are you trying to launch on via the editor to your device or package to make an apk? One thing I can see is you probably want to change your minimum SDK back to 9 or it will only work on any devices running KitKat (4.4) or higher.

Hello there, What I want to do is simply launch via the editor to my device. I will change the minimum SDK back to 9 and see if that works.

Thanks for the reply!

EDIT: I tried setting the minimum SDK back to 9 but it did not show up in the launch drop down:

charanimbp.png

Hi StevenWaltherMedia,

Check and see if these environment variables are set:



ANDROID_HOME = sdk path
NDKROOT = ndk path
ANT_HOME = ant path
JAVA_HOME = java path


Hello there, I checked the environment variables in the computer settings, which is something I haven’t done, but it seems like everything is set up correctly, I’m guessing the install did everything automatically.

Also, speaking of the install, The tutorial asked to navigate to the unreal engine folder and run the ‘tadp-2.0r8-windows.exe’ runtime. This gave me a problem as, if I remember the name of the driver correctly, ‘google usb’ driver was not present. I consulted with my friend and he gave me ‘tadp-4.0r1-windows.exe’. This had the usb driver, and after a bunch of uninstalling and re-installing, we got Unreal 4 to register my device for about 5 minutes before it disappeared.

Sorry about all the confusion :confused:

Everything looks right to me. Did you reboot after installing TADP? Any application (like the launcher or editor) would have kept the old environment.

Yes, I rebooted after I installed it, this was about a week ago so i’ve restarted my computer many times since then.

Should I attempt to uninstall and re-onstall again?

I’m gonna bump this because I still haven’t figured this out.

Hey Steven,

When you’re plugging your Android device into your computer, does it recognize it? it looks as though your device is recognized based on the command prompt window however, I thought I’d ask. Have you allowed your computer to trust the device? Have you tried other USB ports on your computer? I ran into an issue the other day where some of my devices weren’t working in a specific USB port while others were. Please also make sure that you have your developer settings turned on for your device and that USB debugging is turned on as well. Make sure you check your device manager from within Unreal Engine 4 too.

Thanks!

Yes, my device is being recognized, when I type in the ADB devices on the CMD window, it shows up. I also tried three different USB ports on the computer, as well as having my developer settings turned on, with USD debugging checked. I don’t remember if I was prompted to trust the phone or not, how can I bring that window up again?

Also, I reinstalled 4.8.2, and uninstalled the tadp4.0 version I got from the nvidia website, and installed the Android SDK tadp2.0r8-windows that came with the unreal engine. I followed the steps again from the quick start guide, and I still can’t get it to recognize the phone. When i press android support, it redirects me to the same quick start guide.

I am at a point in the games development where I need a build on the phone to test out features, and this problem is starting to make me sad :c

So I plugged my phone into my friends laptop and it connected and UE4 registered it no problem.

I guess the problem is that I have an oldish computer. Still strange that it worked once, though.

I guess all I can do is buy a new computer. Oh well…

Thank you everyone for helping me!!

Hey StevenWaltherMedia,

You’re welcome. I hope that you’re able to get this issue resolved soon. I want to mention that before spending money on a new computer, you may want to try looking at troubleshooting websites for your phone model. It’s possible that a hard reset of the phone or sim card may do the trick but it’s hard to tell from here. Good luck! :slight_smile: