Download

Unreal Studio - Entitlement Check fails when attempting to Import CAD file

Hey all,

I get the following messages when trying to import a CAD file, as of about an hour ago:

…and after about 30 seconds, this pops up…

I have been importing a number of models successfully throughout the day, and suddenly, I am no longer able to do so. Any ideas?

I’ve tested this by first, restarting the editor, then by rebooting my system, and then by disabling my antivirus packages. It gives the same result each time. Is the verification system down, possibly? Is anyone else having this issue?

Thanks!

Rick

Encountering the same issue. Recently updated Datasmith and 4.20.3 to hopefully solve another issue I was having.

It was working for me in 4.20.2, I’ve recently updated to 4.20.3 and also not able to connect. Not sure if it’s because of the upgrade or a licensing server on Epic’s side.

Hi all.

There is no reason we are aware of where the import process should be functional at one point, and then suddenly begin giving this error on the same machine.

Generally, this error will occur if you are experiencing a network issue, or if you have security features on your system that may block the network traffic. See https://unrealstudiohelp.epicgames.com/s/article/Network-Connectivity-Troubleshooting. Naturally this causes me to feel like something must have changed regarding your system during the day, although I am also aware that seems unlikely.

We did attempt to design for possibilities such as this by having the editor remember your previous successful imports and not trigger this error message for a set amount of time, however we have identified that there are some issues with that functionality. Improvements are being made for the 4.21 release.

We are not aware of any issues with our entitlement service at the moment. My primary suggestion would be for you to restart the Epic Games Launcher and the Editor, although it seems that you have tried that.

Apologies for the inconvenience.

Sofar I have tried 2 different accounts, a number of reboots, opened up the ports, stopped any conflicting services (in my case I have teamviewer on this machine). It’s possible it could be a networking related issue on my side, but it was working last week without any issues. I have not tried going back to 4.20.2.

I’ve followed the troubleshooting guide to the letter and still have the issue. Furthermore, if I select “Import from Datasmith”, it does not check for entitlement but does open the Explorer window to search for files. As this is also part of the Unreal Studio plugin, is there any reason this may happen? (Why would it search for entitlement for CAD imports, and not Datasmith imports?)

I am about to shut down my network from the root - cable modem, router, and systems - and reboot. You know, the old “try turning it off and on again” trick. I’ll report back within fifteen minutes with my findings.

**NINJA EDIT: **I just turned off my cable modem and router, waited two minutes, and turned them back on again. Reconnected, turned on my computer, and still the same issue.

Has anyone tested the functionality since my post? There has been some corroboration, above. I’m concerned that, while the service may *show *as being up, perhaps, it’s giving a false positive. (Also, for the record, I have been using 4.20.3 since it came out, and haven’t had an issue until this point.)

Thanks!

Rick

I am currently having this issue as well, looking to see if there’s a fix for it yet?

Looks like this has come up before, as a previous report of this issue just re-emerged with more victims. The link to the other thread can be found here: Unreal Studio - Stuck on Entitlement Check - Unreal Engine Forums

I have already commented in that thread about the existence of this one. Perhaps it may be possible to merge the two?

We have the same issue. Worked last week. Not now.

I have the same issue. Worked yesterday, but not today. No changes made to my system!

Im getting the same issue since last night. Followed every step in the 5 pages thread, I have no antiviruses or any other programs that can change something on my router/lan card. I even did a clean Windows install with format and everything and problem persists. I even called my ISP to see if they are blocking the ports, they said its not on their end.

Probably unrelated, but for the first time I see a red dot in the Epic Launcher next to my name, not sure what that is all about.

I can also confirm the same as FreakyDroid that I am experiencing a loss of connectivity to the Epic Launcher, as is a colleague of mine (we work off separate ISPs and are experiencing the same issue on personal home workstations).

While this may be unrelated to the problems I’ve been having in establishing my Entitlement Check for Datasmith without timing out first, I wouldn’t want to rule it out either.

Adding my name to the list. I imported a file fine. Then not even 20 minutes later I received the same issue as Kromenoi and everyone else, and since then I’ve not been able to import anything despite any steps I follow.

It happened to me last night. 2 days ago I could able to import Datasmith file. But yesterday I noticed that the launcher updated itself and restarted. I think after that datasmith importing stopped working.

ANY SOLUTIONNNNN…??? HEEEEEYYYYY MR. UNREALs… ARE YOU STILL SAYING THAT YOU ARE NOT HAVING THIS ISSUE…???

Hi all,
This morning I’ve got the same problem.
I tried to do this but doesn’t work.

Someone please can help me?

Thank you all for the reports. There does seem to be some underlying issue and we are looking into it.

Hey Stephen, are there any updates on when things will be fixed? I’m sure Epic is aware that the type of work Unreal Studio is targeted towards has much shorter deadlines. When the server goes down like this, it’s basically show stopper.

count me in. same problem here. everything was fine until today.

I’ve just uninstalled my anti-virus app, but NO LUCK. I don’t think the problem is on our end. epic pls do something, loads of work awaits, we really need datasmith

Epic Staff has commented above. They’re aware of the issue, and are looking into it.