Download

Unreal Source building crashes/freezes computer problem.

See subsequent post - I am not really happy but this seems to have compiled now.

Have unreal source 4.15 and 4.22 downloaded. Attempting to build in Windows 7 with any version of Visual Studio (2015,2017,2019) either crashes machine completely (blue screen claiming an unknown harware error) and I find it turned off, or, freezes the machine. Get an odd rectangular screen aberration in top left corner of second monitor - half mottled red and half black. Thought my video driver (GeForce 1050 Ti) might be to blame so I have been through the process of uninstall and re-install on video card, Visual Studio versions, Framework versions - but nothing makes any difference. Halfway through build and Goodnight Vienna. The same download of 4.15 compiles first time on another very similar computer.- just the wrong computer dammit.
I started up in Safe mode with network support last night and left it building. It has now reached the end of the build without crashing but it reports 1 failure. Log shows this:-

4.22\Engine\Plugins\Messaging\UdpMessaging\Intermediate\Build\Win64\UnrealMultiUserServer\Development\UdpMessaging\UnrealMultiUserServer-UdpMessaging.exp

6> [59/84] UnrealMultiUserServer-Core.lib

6>Module.Core.1_of_11.cpp.obj : fatal error LNK1143: invalid or corrupt file: no symbol for COMDAT section 0x4

6> [60/84] UnrealMultiUserServer-Core.dll

6>Module.Core.1_of_11.cpp.obj : fatal error LNK1143: invalid or corrupt file: no symbol for COMDAT section 0x4

6> [61/84] UnrealMultiUserServer-CoreUObject.lib

Any comments or suggestions would be gratefully received. I do not believe these files are really corrupt since they work on another machine. I think they are referencing something in Windows7 which is not right and which is causing ‘something very bad’ to happen to my video.
What would you do next?

I have since tried building again in the normal Windows7 environment and the build did not crash or freeze - but reports the same errors that I got in safemode- so it seems that these errors are not the ones that were causing the crash/freeze behaviour.

This is a follow up to my original question because I might have muddled my way through to making it work.

  1. I noticed that, in visual studio under tools-extensions and updates, UnrealVS was not installed so, I went and got that and installed it. (not sure if that has affected what happens or not). I swear blind that I told the VS2017 to include Unreal extensions when I re-installed.
    Anyway,
  2. Tried compiling again in Windows7 full environment (not safe mode) and the computer did not crash or freeze. But I got the Error messages that are in the image on my first post. So, it seems that it was another project or module that was causing the crash and since this is now built (in safe mode) it does not cause a problem now.
  3. Focusing on the word duplicate in the Error message description I went and picked on the UnrealMultiUserServer project in the solution. Right click and clean, then build. And it builds.
  4. Now I build the whole solution - And it builds!

Run the UE4 startup project (not debugging) and slow but sure it starts up. I have created a project and it all seems to be ok. But I am not really really happy because I do not know what the original problem was that crashed my machine so many times and I don’t know whether what I have done has solved the problem or merely masked it and something is hiding now which will come back to bite me - perhaps some aspect of compiling projects will fail in the future or some other strange effect.

Anyway, saga over for the moment. Any comments or observations are very welcome.
cheers
Podge.

Not sure about your crash, but if by “slow but sure it starts up” you mean that it takes a long time for the visual studio project to open, you might be running into the UnrealVS performance issue I ran into here.

@drichardson - thanks for the information. I will certainly try that out. Pretty sure I solved my freezing and crashing. Turns out it was a build up of dust on the cpu heatsink causing overheating. The intensity of the processor use by visual studio just drove it over the edge sometimes. Turns out that compiling from source is quite a good stress test. Cleaned it up and it is fine now. Stupid eh?