Unreal Project Launcher gets stuck in Visual Studio Express

Hi, total almost newb here, haven’t used unreal editor since 2004, and that was only for mapping for Raven Shield. I subscribed to UE4 because I’m psyched about the Ground Branch game, and wanted to mess around again making first person shooter maps.

At first, the Unreal Project Launcher would error when I selected Code First Person because it thought VSE was not installed. I had initially installed it in a non-default location. So I uninstalled it, reinstalled it on C:, and found on this very answerhub site how to search my registry for the VS120COMNTOOLS entry and remap the location to where the program actually is now. So I’ve made it one more step, and thank you.

Now when I click Code First Person, UE4 minimizes after the “launching” splash-dialog, and VSE comes up. A lot of stuff apparently gets compiled, as shown in a little statusbar on the bottom. Then it stops. That’s it, UE4 never comes up. I thought maybe it was just another symptom of the VSE uninstall failing to clean up the registry, and tried to go at it backward, by changing a map I made with no code (edit > project settings > maps and modes > Editor Startup Map to FPSmap as per the tutorial here:

but no joy, that item doesn’t exist in the drop-down menu there.

I looked at this,

https://docs.unrealengine.com/latest/INT/Programming/Development/VisualStudioSetup/index.html

too, thinking maybe VSE needed some tweak to function properly with ue4, but it didn’t seem like that was what I was looking for.

Maybe I’m missing another registry fix, that would allow unreal editor finish launching after it calls on VSE?
Thanks in advance for any assistance!

This computer: CPU i5quad, RAM 8GB, Nvidia GF650, Windows7

Hi echeddar,

I’d like to walk through this from the start with you.

  1. On the Launcher, click Launch
  2. On the Unreal Project Browser, select the New Project tab, choose Code First Person, give it a name and click Create Project
  3. Visual Studio will open with your project solution selected
  4. Set the Solution Configuration to Development Editor and the Solution Platform to Win64
  5. Choose Build > Build Solution
  6. …wait for it to complete…
  7. Back on the Launcher again, click Launch
  8. On the Project Browser, select your new project and Open

At this point your project should open without issue. If you are experiencing a problem during any of this, please let us know which step, and any error messages you receive.

Thanks

Thanks, it worked!

To clarify a little more, in the Properties box, in the lower right of VSE, I clicked on the wrench icon. Then a dialog came up, and I could see that “Development_Editor” was selected for the dropdown under Configuration and “x64” was selected in the dropdown under the heading Platform. I clicked OK to close the dialog.

Then I clicked BUILD in the top menu, and clicked the first item, “Build Solution”

Worked like a charm, thanks!