Unreal iOS remote build

Hello,

I’ve been following this tutorial that I found on the Unreal forum and I would like to set up a remote build between our PCs and mac.

In the above tutorial, I did the following changes:

  1. I had compiled the Unreal Engine source code in a separate folder and not in the C:/UE4 in the PC
  2. I got the certificates from the university such as provisioning profile, certificates etc.
  3. In the Rsync section, I had modified the Rsync conf file. I had added the port 65432 to it in order to let us bypass through the university firewall.
  4. In the rsync conf file , I gave the subnet mark in the host allow field.

Connection between PC and Mac was tested using Delta copy client and it works.

(As I type this, I am moving the contents of source folder to the root/UE4 in both the PC and MAC to see if there is any difference)

However, I am stuck at the part when trying to generate SSH key. I get the following error:

LogWindows:Warning: CreateProc failed (2) C:/Program Files/Epic Games/4.10/Engine/Build/BatchFiles/MakeAndInstallSSHKey.bat “D:/DeltaCopy\ssh.exe” “D:/DeltaCopy\rsync.exe” :65432 “\\students\loginId\IGMProfile\AppData” “/cygdrive////students/loginId/IGMProfile/AppData” “…/…/…/Engine/”

Note : I am working in my University lab.

  1. I would like to know if there is an official Epic tutorial for iOS remote build?
  2. Is it necessary to download and compile the Unreal Engine (through github) to make it work with remote build or can I use the default launcher version?
  3. If I have to download the source code and compile, is it always necessary to place it in the /UE4 folder in both the pc and mac.
  4. File-> Package Project → IOS doesn’t give me any output.
  5. Since my Appdata is in my university`s network domain and it is not mapped to any letter on the pc, will that be a problem?

Please let me know,
Thank you

rcp1,

Here are the steps you can use to set iOS remote build up.

Allow remote hosting on a Mac:

  • Open the System Preferences on the Mac machine
  • Open the Sharing window
  • Check the Remote Login checkbox

Install DeltaCopy on Windows:

  • Create a folder named ‘DeltaCopy’ in the C:\Program Files(x86) folder
  • Download DeltaCopy - DeltaCopy Download - Rsync for Windows
  • Run the DeltaCopy setup
  • Press Next in the Customer Information window
  • Set the Destination folder to C:\Program Files(x86)\DeltaCopy
  • Press Next to set the Destination folder
  • Press Install
  • Close DeltaCopy

Setup Editor for SSH:

  • Select Edit > Project Settings > IOS > Build > Remote Build Options
  • Enter the Remote Server Name (Computer name of the mac)
  • Link the Delta Copy install path
  • Enter the Remote User Name (User name of the mac)
  • Press the Generate SSH Key button
  • Enter Yes into the terminal
  • Enter the password of the Mac computer
  • Press Enter twice to enter an empty passphrase
  • Enter the password of the Mac computer again

Please let me know if you run into any further complications.

Thanks!

Hi,

Thanks a lot for your answer.

After following your steps, we did not get the error when clicking the “SSH Key” button anymore. However, due to our university firewall configuration, we can’t use the default ssh port 22 and our rsync daemon is configured to listen to the port 65432 instead . We tried specifying the port in the remote server name field under the format servername:port but that didn’t work.

Please let us know how to proceed from here.

I have spoken with our Developer and we have entered a Jira report for this issue. UE-24679 is what you’ll reference if you have any additional questions on the status.

Thank you!

failed for me too when I tried to generate an ssh key

LogWindows:Warning: CreateProc failed (2) D:/Program Files (x86)/Epic Games/4.11/Engine/Build/BatchFiles/MakeAndInstallSSHKey.bat “D:/Program Files (x86)/DeltaCopy\ssh.exe” “D:/Program Files (x86)/DeltaCopy\rsync.exe” admin MACNAMEREDACTED"C:\Users\Chad Robert Morgan\AppData\Roaming" “/cygdrive/C/Users/Chad Robert Morgan/AppData/Roaming” "…/…/…/Engi
n

after a little investigating, turns out D:/Program Files (x86)/Epic Games/4.11/Engine/Build/BatchFiles/MakeAndInstallSSHKey.bat doesn’t exist

went to github and copied the bat file over, it still fails

belay my last - I copied the file over wrong. I’m getting the terminal now

I’ll have to fight with this some more - the tool isn’t generating the key

it’s not asking for a second entry of a password. I’m getting "Unexpected local arg: /cygdrive/C/Users/[my name]

rsync error: syntax or usage error yadda yadda yadda

UE-24679 is still on our to do list. Spectral Ink, if you believe that your issue may be different, you might want to post a separate post on AnswerHub for additional assistance.

Thanks!

Hi, thanks a lot for your answer. When you said “Link the Delta Copy install path”, what do you mean by that? I did not see somewhere ask something like that.

sorry ignore my question, just found out…

I’ve founded out an issue generating a ssh key!!

If there is a space in your computer name (The one with windows) it won’t work and and throw up an error in the cmd console before asking the password of the mac again.