Unreal Installer Service Pack 1 - Cannot install

So I downloaded the UE setup, and prompted it to run. Once the installer initializes it says

“Microsoft Windows 7 Service Pack 1 is required when installing on Windows 7. Please install SP1 and run the installer again.”

Then proceeds to close itself.
Here’s the kicker, I installed SP1 immediately after through windows update but it doesn’t seem to have worked. I tried a manual install and still have no such luck.

Could anyone provide some insight as to what is happening and some thoughts on how to fix this issue?

Sorry to hear that you are running into issues installing. Did the SP1 install complete successfully and were you prompted for a restart after the SP1 install?

To help further we’ll need more info about your Windows environment and possibly logs from the installer which should tell us exactly why it failing to properly recognize your SP1 install. This link outlines some steps for obtaining the log in the MSI (Windows only) installation issues section: LINK

I’m running Windows 7 Ultimate (service pack 2 originally).

here’s the [msilog][1]

[1]:

I believe the code is 1603. I’ll look into that for now. Let me know if the log helps at all!

I Fixed the issue, the problem lay within the compatibility mode!

Windows itself solved the issue when I right clicked and chose the shell extension “Troubleshoot compatibility”

The installer booted happily with no issues!

Glad you got it working in the end. I believe 1603 implies that one of the installer custom actions is failing and a closer look at the log would probably pinpoint the issue. It looks like the msilog link that you posted points back to this thread and not the actual log. If you still have that log sitting around, perhaps you can zip it up and post it so I can have a look. I would like to fixup the underlying issue so we can prevent others from encountering it.

This was same error I got and luckily troubleshooting compatibility fixed it!

I also got the same problem but I saw Meat Juice’s answer and I got it fixed.Tnx for sharing Meatjuice.

Im on windows 10 and to see this error well i was amazed but thanks MeatJuice. worked liked charm what ever it did in there…