Unreal Engine Won't or Can't Install

Hi there. I just freshly reinstalled Windows 10 20HC, and did all the updates. I updated my graphics card driver. I updated Windows itself. Then I downloaded the Epic Games Installer. I chose “Open” from the Edge browser panel at the bottom of the window. It opened. Then I tried to install Unreal Engine – and trust me, I’ve tried this as Administrator too – and it just won’t budge. It says “Not installed, Unreal Engine 4.26.1” in the top right corner. But when I click on it, I just get a dropdown that says, “Unreal Engine 4.26.1” as an option. I click it and . . . nothing happens. The very first time I tried this it booted me out saying I didn’t have Permissions to install the game, and hasn’t worked ever since. Please help. Yes I am logged in as Administrator, and yes, I’ve tried launching Epic Games Installer as Administrator. I’ve tried removing it, repairing it – both operations terminate early, leaving the system unmodified – and now I can’t get rid of it. Next step is to reinstall Windows. Can anyone help?

have you solved it? I have the same problem

I’m sorry you are experiencing this problem… Keep trying, it will be worth it :slight_smile:

Anyway, can you please send a screenshot of the odd behavior in the Epic Launcher? I might be able to help

I am having the same exact problem on a Mac mini m1. Any ideas?

I am having the same problem on a new xps17.