Unreal Engine will not open C++ new project on Mac OS

At first I tried to compile with Xcode and thought it was not working because I got version 9.1xx so I decided to try Visual basics 2017 and find out there is no C++ extension for the Mac -_-. I install Visual code and install the C++ extension, Unreal extension, Mono Extension and LLDB debugging extension and still the same error. I am new to game developing and just getting this thing to work is already stressing me out. Below is the error message that I am getting. Please help!!

The project could not be compiled. Would you like to open it in Visual Studio Code?

Running Mono…

Setting up Mono
/Users/Shared/Epic Games/UE_4.18/Engine /Users/Shared/Epic Games/UE_4.18/Engine/Binaries/Mac
@progress push 5%
Parsing headers for MyProject5Editor
Running UnrealHeaderTool “/Users/user/Documents/Unreal Projects/MyProject5/MyProject5.uproject” “/Users/user/Documents/Unreal Projects/MyProject5/Intermediate/Build/Mac/MyProject5Editor/Development/MyProject5Editor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed
Reflection code generated for MyProject5Editor in 9.4644434 seconds
@progress pop
Performing 6 actions (8 in parallel)
[1/6] Compile SharedPCH.Engine.h
In file included from /Users/Shared/Epic Games/UE_4.18/Engine/Intermediate/Build/Mac/UE4Editor/Development/Engine/SharedPCH.Engine.h:138:
In file included from /Users/Shared/Epic Games/UE_4.18/Engine/Source/Runtime/Engine/Public/EngineSharedPCH.h:300:
Runtime/CoreUObject/Public/UObject/UnrealType.h:3285:37: error: lambda capture ‘LocalMapLayoutForCapture’ is not used [-Werror,-Wunused-lambda-capture]
[LocalKeyPropForCapture, KeyPtr, LocalMapLayoutForCapture](void* NewElementKey)
Runtime/CoreUObject/Public/UObject/UnrealType.h:3298:41: error: lambda capture ‘LocalMapLayoutForCapture’ is not used [-Werror,-Wunused-lambda-capture]
[LocalValuePropForCapture, ValuePtr, LocalMapLayoutForCapture](void* NewElementValue)
Runtime/CoreUObject/Public/UObject/UnrealType.h:3808:47: error: lambda capture ‘LocalSetLayoutForCapture’ is not used [-Werror,-Wunused-lambda-capture]
[LocalElementPropForCapture, ElementToAdd, LocalSetLayoutForCapture](void* NewElement)
3 errors generated.
ERROR: UBT ERROR: Failed to produce item: /Users/user/Documents/Unreal Projects/MyProject5/Binaries/Mac/UE4Editor-MyProject5.dylib
Total build time: 26.47 seconds (Local executor: 0.00 seconds)

Try using Xcode 8.3.3, I found that latest version of Xcode doesn’t work for version 4.18

I just tried that and I get the same error -___- nothing seems to work. I don’t know what the problem is

Finally got it to work. Uninstalled all versions of Xcode and reinstalled Xcode 8.3.3. I had both X code before. Thanks a million

An error occurred while trying to generate project files.

Running Mono…

Setting up Mono
/Users/Shared/Epic Games/UE_4.19/Engine /Users/Shared/Epic Games/UE_4.19/Engine/Binaries/Mac
Discovering modules, targets and source code for project…
Triggered an exception while looking for SDK directory in Xcode.app
System.IO.DirectoryNotFoundException: Directory ‘/Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs’ not found.
at System.IO.Directory.ValidateDirectoryListing (System.String path, System.String searchPattern, System.Boolean& stop) [0x00000] in :0
at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000] in :0
at System.IO.Directory.GetDirectories (System.String path, System.String searchPattern) [0x00000] in :0
at System.IO.Directory.GetDirectories (System.String path) [0x00000] in :0
at UnrealBuildTool.AppleToolChainSettings.SelectSDK (System.String BaseSDKDir, System.String OSPrefix, System.String& PlatformSDKVersion, Boolean bVerbose) [0x00000] in :0
WARNING: Exception while generating include data for UE4Editor: Invalid SDK MacOSX.sdk, not found in /Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs
Generating data for project indexing… 0%@progress ‘Generating data for project indexing…’ 50%
WARNING: Exception while generating include data for HelloWorldEditor: Invalid SDK MacOSX.sdk, not found in /Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs
Generating data for project indexing… 50%@progress ‘Generating data for project indexing…’ 100%
ERROR: UnrealBuildTool Exception: Invalid SDK MacOSX.sdk, not found in /Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs