Unreal Engine website infinitely redirects when approving Metahuman early access

I tried asking this question to Epic’s main support via their ticket system but they just immediately closed my ticket and told me to ask here, but there’s no website bug section so apologies if this is the wrong place, as I could not find any other section for web issues.

I have applied for access to MetaHuman on Unreal’s website with my Epic account. It says “Your access to MetaHuman Creator is confirmed. Stand by while we redirect you.” It redirects me to the same page in an infinite loop several times a minute. I am on Windows 10 64bit. This happens both in Firefox and Microsoft Edge AND Chrome, and I tried both with my VPN on and VPN off, both regular browsing and incognito. The loop continues infinitely in all combinations. Can anybody tell me how to actually access MetaHuman or to make this redirect function properly?

Thank you.

Having the same problem, both on chrome and edge running on windows.

I have the same issue, any solution?


Same issue here, hopefully they’ll get us a fix soon

Same here, hopefully they’ll figure it out soon. I’ll submit a ticket too if I can find where to do it!

Same here. Not a bug? Must be a feature then. This section is also buggy. Was logged in but prompted to log in.

I’m also experiencing the same issue…OS is Win Server 2019 64bit. Firefox/Chrome/Vivaldi all exhibit the same behaviour.

Same… :-/ I downloaded Bridge from the Quixel Website and installed - there’s an icon on the left that looks like a person in a circle and that gives you access to the Metahumans plugin.

But then it takes you back to the Metahuman unreal page and goes back into that infinite loop

Someone from Epic please address this. You’ve given access to something that poeple are unable to use. I’ve read simliar posts on other forums. The access is broken. Please fix it.

1 Like

I don’t know if this will help or not, but I just ran into a similar issue with Epic’s page infinitely redirecting, and was able to stop that by removing my browser’s stored site data for unrealengine.com and epicgames.com.

This was for Firefox, and was done by opening Settings, Privacy & Security, Cookies and Site Data, Manage Data, finding and selecting unrealengine.com and epicgames.com and removing the data for those.

I cleared my cookies and it stopped the infinite redirect. But now the website just says 403 Forbidden. I have a feeling it has something to do with cookies expiring but somehow it’s not integrating well into their tracking system. So you’re logged in, but the cookie is expired, so it goes in this loop of “hey you’re logged out because this cookie is expired, oh wait you’re logged in, but you’re logged out”

I could be totally wrong but still this issue is super annoying, it happens at least once a week when trying to access their website.

Same deal for me as well… Where’s the support?

Found the answer to my case
I disabled my browser AdBlock
and it worked !!!

If you’re curious, it was my ad blocker blocking tracking.epicgames.com. Once I whitelisted it the epic games launcher fired right up…

Go to epic account setting in your browser
Then try logging out your epic account from every device u have logged in,
Then revoke the metahuman access from that account.
Now go to metahuman creator website disable adblocker and try logging in with a google account which u have never signed in before in epics,
This worked for me
Thank you

1 Like