Unreal Engine unable to generate project files

I am trying to follow [this tutorial][1]

to set up Unreal Engine from source. However, whenever I run the Generate Project Files.bat I get this:

along with many more errors very similar to the ones shown. I tried re downloading the “Ado.Build.cs” File, but that didn’t work. Any help/advice would be much appreciated.

Hello JackpotRobot,

This could be related to your Visual Studio installation or related SDKs. What version of Windows and Visual Studio do you have installed? Do you have the Windows 8.1 SDK installed? Do you have the binary engine? If so, are you able to compile blank code projects?

Could be need to run under ADMIN privileges?

Hey Matthew, thanks for your reply. I am trying to compile this on a windows 10 computer and then bring it over on a flash drive to a windows 7 computer. I installed both the windows 7 and windows 10 SDKs. I am not at this computer now, but I believe I installed Visual Studio 2010. Sorry for my lack of knowledge, I am quite new to this. I am not sure what the binary engine is. Also, regarding the flash drive thing, this is possible right? The Windows 7 computer does not have internet connection. Thanks! :slight_smile:

Hey , thanks for your reply. This may be the problem. I will try doing this when I have access to the computer I am compiling it on next :).

We haven’t heard from you in a while, JackpotRobot. Are you still experiencing this issue? If so, did you ever get to try what suggested? What were the results? In the meantime, I’ll be marking this issue as resolved for tracking purposes.

Yeah, I managed to find out the problem I made a really… really stupid and obvious mistake… I never ran the setup.bat xD Thanks for your help.