Download

Unreal Engine- UI blurry?

My unreal engine UI does not look sharp and is blurred on my 1080p monitor. Subsequently, the viewport is slightly blurry and edges are jagged . I have changed the setting of the viewport to cinematic yet this still persists?

I have two images available where the first is mine and as you can see, the image is slightly blurred and text on the left-hand side is not sharp.

83d11cd18b832a39a1edee9cbe675657f84e2f7b.jpeg

The second image is from a YOUTUBE video which has been compressed(by youtube) yet it still looks better?

8b808ed6ef5f68b0e6231ab0e08090a7f492b765.jpeg

Is there a solution to fix the blurriness of the UI?

If you are using an HD display, it may be because Windows is scaling up the UI so stuff doesn’t appear too small on screen. Go to where the engine is installed (usually C:\Program Files (x86)\Epic Games\4.xx\Engine\Binaries\Win64), right click the UE4Editor executable, and open properties. In the compatibility tab, tick “Disable display scaling on high DPI settings” and open up the editor again. Everything should now appear sharper.

Hope this helps.