Unreal Engine Setup Wizard ended prematurely

I have an issue with installing software, it shows getting to installing directx and then rolls back update and displays this message. What’s fix for this issue?


[link text][2]

Sorry to hear you are having install issues. We can probably help you more if you post your installer logs. To get installer to generate logs you can try steps outlined in MSI (Windows only) installation issues section of this thread:

Or you could follow these steps:

  1. Place msi on root of C drive

  2. Start a cmd prompt as administrator
    (Start-> type cmd in search bar
    and right click cmd.exe and select
    Run as Administrator)

  3. You should see a command prompt that
    says Administrator in title bar

  4. Enter following command(be sure
    to replace
    ‘UnrealEngineInstaller.msi’ with the
    actual msi file name):

    msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt

Once you post log we’ll be able to pinpoint issue and try to get you past it.

I have attached log file above.

MSI (s) (00:90) [21:14:31:949]: Executing op: CustomActionSchedule(Action=QtExecSetPermissionCmdLineRun,ActionType=3073,Source=BinaryData,Target=CAQuietExec64,CustomActionData=“icacls.exe” “X:\Game Development\Engines\Unreal Engine” /grant “BUILTIN\Users”:(OI)(CI)F)
MSI (s) (00:A8) [21:14:31:960]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI91C4.tmp, Entrypoint: CAQuietExec64
MSI (s) (00:84) [21:14:31:960]: Generating random cookie.
MSI (s) (00:84) [21:14:31:961]: Created Custom Action Server with PID 10172 (0x27BC).
MSI (s) (00:54) [21:14:31:974]: Running as a service.
MSI (s) (00:54) [21:14:31:975]: Hello, I’m your 32bit Elevated custom action server.
CAQuietExec64: Error 0x800700d8: Command failed to execute.
CAQuietExec64: Error 0x800700d8: CAQuietExec64 Failed

After looking at your log, it seems that installer can’t give Epic program data folder proper permissions for your Users group. One thing you could try is to manually create this folder and give Users and Adminstrators full control:


After you do that, run installer again.

I have created the “Epic” folder and assigned permissions, i am on windows 7, administrator account and have ran log command in cmd prompt under administrator too, i don’t know why there would be a permissions issue…

Anyway, still an issue. I have attached new log to my reply.link text

Do you have icacls.exe in your system32 folder(usually in c:\windows\system32)? If you have it, is your windows path setup in a way that lets you access icacls.exe? You can check by opening a command prompt to any folder, except for c:\windows\system32, and typing following command:

icacls /?

If you see help info for icacls.exe then you are good. If you see ‘icacls’ is not recognized as an internal or external command then we have a problem. You’ll need to make sure your System Variables Path has your system32 folder in it.

Just typed it and help info appears. To note i have build engine fine and have had no problems in past with other installations of engines. It just seems to be this one…

I have attached my dxdiag file too, maybe that might help.

link text

Sorry for delay, I’m still investigating. It is failing trying to make a icacls.exe call but I’m not sure why. This is command installer is failing to execute:
icacls.exe “C:\Program Files\Unreal Engine” /grant “BUILTIN\Users”:(OI)(CI)F

Do you have skype or some way of communicating, maybe we can try using teamviewer or something similar to figure out what’s wrong. Like i said, i have a standard windows 7 Home edition installation, where i am an administrator, UAC is disabled and i am running installation an administrator.

Still no solution…

I am having this same exact thing happen, I am running on Windows8.1 and have tried all suggestions to resulve problem but nothing has worked. Would love to get this working asap. If anyone has a solution please let me know. I am lost at this point. Thank you

@ireheart, Could you create the “C:\Program Files\Unreal Engine” folder if it does not exist and then run following command from a command line and tell me what happens?

icacls.exe "C:\Program Files\Unreal Engine" /grant "BUILTIN\Users":(OI)(CI)F

If there are no errors, perhaps you can try installer again after above command runs successfully.

I already had Unreal Engine folder, I ran command and no errors happened, just a small black box appeared for a split second I couldn’t see what was on it if anything. I am about to try Installer again. fingers crossed! Thanks again for your patience and support.

that did not work it did same thing stopped half way through Directx and sayd wizard ended prematurely.

@AlphaHemi, that message was intended for Ireheart. You are having a different issue as I stated in your question here:

C:\Windows\system32>icacls.exe “C:\Program Files\Unreal Engine” /grant “BUILTIN
processed file: C:\Program Files\Unreal Engine
Successfully processed 1 files; Failed processing 0 files

Done that, but still same error

I ran installer and generated another log:

.link text


We apologize for lack of follow up on this issue. Do you have any update on it? Is problem still occurring for you, or were you able to find a solution?

Definitely please let us know if you were never able to get editor to run, and we will be glad to discuss our options with you.

We are marking this as “resolved” for tracking purposes, until we hear back from you.


If you are still encountering this issue, I want to let you know that we have made some changes to installer internally that will allow you to bypass step that is causing problem. I’ll update thread when that version of installer becomes available for download.

Your installer is failing to setup folder permissions. latest version of installer supports command line parameters that will allow you to bypass portion of install process that sets up these user permissions but you’ll have to manually apply proper permissions to install and programdata folders. I have outlined process below.

If your installer log has one or both of these failures, try workaround outlined below

CustomAction QtExecSetPermissionCmdLineRun returned actual error code 1603
CustomAction  QtExecPermissionAppDataCmdLineRun returned actual error code 1603


  1. Download latest Unreal Engine Installer
  2. Run installer using following commandline(replace C:\UnrealEngineInstaller.msi with path/name of installer you downloaded): msiexec /i “C:\UnrealEngineInstaller.msi” SKIP_PERMISSIONS_INSTALLFOLDER=“1” SKIP_PERMISSIONS_APPDATA=“1” SKIP_AUTOLAUNCH=“1”
  3. Set user permissions on install folder. This can be done a number of ways but simplest may be to run this commandline(replace C:\Program Files\Unreal Engine with your selected install location): icacls.exe “C:\Program Files\Unreal Engine” /grant “BUILTIN\Users”:(OI)(CI)F
  4. Set user permissions on ProgramData folder. This can be done a number of ways but simplest may be to run this commandline(replace C:\ProgramData\Epic with location of your Epic AppData folder): icacls.exe “C:\ProgramData\Epic” /grant “BUILTIN\Users”:(OI)(CI)F
  5. If steps 3 and 4 completed successfully, try launching using Unreal Engine shortcut on your desktop or in your start menu