Unreal Engine Not Downloading

Im trying to download UE4 but the problem is that its not using my internet,my internet is more then fine,im starting to loose my coolness here,yes it is enable on firewall my pc/internet is perfectly fine…the only think here that is not fine is Epic Game Launcher server…■■■■ i even pick C++ language lesson for this…

Hello XxWarsongxX ,

I’m sorry to hear that you are having trouble. Could you please provide more information? Are you unable to install the launcher, or are you having trouble installing the engine after installing the launcher? What error message, if any, are you getting?

Okay,I thought no one would ever reply,but thanks…Here how it goes sometime my download stucks and the weird part is that my network status shows that my packets is still moving in,reach like 1 GB of recieved packets but unreal engine still show its current download percent,stuck at wherever it is furthest was 37% …my download speed is 200KB only…Yes i run it as an Admin,firewall approve,Antivirus is Panda Free,enable of disable protection still the same I have no Virus/malware or so,nothing else is using my connection except Epic game Launcher…Please Help im dying…

cmon guys…21 views and no reply…?

Hi Warsong,

Thanks for the info. I have seen a couple of similar reports over the last couple of days. Could you do me a favor and attach your debug and dxdiag logs to this post? The process to generate those can be found here.

Hi XxWarsongxX,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.