Unreal Engine not downloading with full speed

I have slow internet connection (200KB/s). What I am doing is to make it download the editor as fast as it can. It should utilize full internet speed but instead it drops rapidly. Funny thing is that when I start browsing, speed goes up. When I stop browsing, speed goes down. It should be doing other way around. Chrome uses a lot of memory. So I like it to stay close totally. But when I close it, speed goes down.

Is it something added by developers in Epic Launcher? Why can’t it utilize full internet speed without making me open and browse internet. I just want it to download fast while I open some other application which doesn’t use internet and focus on it without having fear that Epic Launcher will stop downloading.

Hi Faisal Aslam,

This is the first time we have heard of an issue like this, there is currently no code in the launcher which would cause it to act this way.

One thing to make note of is that when the launcher is not being interacted with directly it will render at a much slower rate. This is for performance reasons, and can sometimes give the perception that the download is going slower then expected. The actual download however is still running at full speed, just not updating the launcher.

Out of interested how big a difference are you seeing between the high and low download speeds?

Hi Faisal Aslam,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that Barnabas mentioned above. Then post back here with the requested info.



I have the same issue atm. I download with 5.6 Mb/s on steam and less than 50 Kb/s on the launcher. I also cant download the launcher from the website as I don’t get any speed there. My friend downloaded the .msi for me and then the 90MB in the beginning where a pain aswell as it went from 100kb/s to 6 MB/s for 1 second and straight back to 100kb/s. The Engine download itself went with 1 MB/s even tho I had full speed (stopped the engine download and downloaded a game from stemw ith 5.5 MB/s).

hello everyone,

is the problem for others fixed or do i have to open another question to get a fix?
its one of the first threads i found after searching.

I have the same problem, its like downloading 1 asset pack randomly normal at 20mbs then randomly 1mbs or even 700kbs or 3mbs but its stable around that for long time and randomly reverts back to full speed or not with new assets when finished.
im lucky if i come back to the launcher and it loads 5 bigger asset-packs wich happens randomly just fine.

its something different than tj meant that its a feature not a bug that does it by itself for performance improvements.this problem happened on that machine i think for the first time for me, or in that often appering, but its the rendering machine so it has to work there.

im testing it now on laptop from different networks to elimiate that possibility but its clear something happens if i just reboot the machine or close unreal launcher but when i do so the downloadque is empty.

i tried fixing it with disabling some windows update funktions or background tasks, checked dns and lan/wlan connection, changing chache folder and so on. tried the config fix or make a downlaod speed cap in epic launcher, nothing showed the results i want.

Infos about my setup: newest drivers for newest windows 10 version all updates installed. unreal engine on c: drive, epic cache folder on e: diskdrive.
(pagefile or cache only for c: drive, indexing off, timestamp off, hibernate off, kernel swapping off, prefetch off, boot files defrag off, win event logging off, 8.3 name off,…)
pc-parts highest-end.

also another problem just on this machine just from beginning the way it installed itself was very slowly, for 10´s of minutes at first whith no progress or donwloads speeds at times.
its that i cannot click on something in the marketplace just the bar above with the marketplace or my bib. maybe thats a problem related to this and help you.

thank you,


i can tell for him if its the same thing at my end, its real time displaying the actual speed confirmed from task manager or by disk write speed and by feeling that it worked just fine 10 seconds ago and then it takes forever for little packs i downloaded before in much less time.