Unreal Engine Multi-user Enviroment


I’m installing the Unreal Engine via Epic Launcher on a Mac lab that is domain joined.

If I install the Unreal Engine under a admin account, log out and login as a student, I can’t see the Unreal Engine as being installed. It asks me to install the Engine in /Users/Shared/Epics Games and /Users/Shared/UnrealEngine

Since the Engine is already there, it ask’s for the directories to be emptied before continuing.

I’ve given access to both folders full read\write to all users which does not make a difference. It’s a bit odd that it installs to a shared location, yet can’t be seen by anyone else who logs in apart from whoever installed it in the first place.

Clearly there’s something that needs to be registered within the users profile to indicate the Engine as being installed. In a Windows environment, we don’t have this issue.

Has anyone got this to work in a multi-user environment?

Using Mojave 10.14.5

Thanks in advance.

Are you saying if you log in as the student account the app does not show up on the dock or if you go into the User/Shared/Epic Games folder that folder looks empty? I think to help we’ll need more specifics as to how it ‘can’t see the Unreal Engine as being installed’.

Basically, all the required files are there. If I login with the account I installed Unreal Engine with, I can launch the Epic Launcher and from there launch the editor and do everything else etc. I then log out and login with a standard domain account (but this problem exists even if a local standard user account), I can see Epic Launcher in Applications, and start it up fine, however, on top right corner, where it would say Launch Engine, it says ‘Install’, for some reason it can’t see the already installed files.

If I click ‘Install’, it points to where it would like to install the Engine (/Users/Shared/Epics Games), which the of course is already occupied with the files. I don’t see why it can’t see the already installed Engine. Both locations /Users/Shared/Epics Games and /Users/Shared/UnrealEngine have been set to full read/write permissions for everyone.

Hope that clears up any confusion. Thanks for responding.

Try the instructions at the bottom of this thread:


The link provided was taken down in March 2022.

I’m experiencing the same issue as the OP. Unreal Engine was installed under the local computer’s administrator account. When other user logs in and launches Unreal Engine from Epic Games Launcher the yellow button at the top right corner says Install instead of Launch.

In the launcher, go to Settings->Edit Vault Cache Location. My guess is that it is set to someplace buried in the original user’s directory. Change that to a shared location and see if that takes care of things.

The ‘Vault Cache Location’ is already set to [/Users/Shared/UnrealEngine/Launcher/VaultCache]
That sounds like a shared location. Not sure what I would change it to.

This solution on Reddit worked: