Unreal Engine missing in launcher and "add" button greyed out

Hi folks. I can’t install Unreal Engine. There is no option available in the launcher and the “add” button is greyed out, so I can’t click and see the versions to download.

Do you know how can I solve it?

Thank you


I think he has the same problem that I have. Even clicking there it just redirects to Library and can’t actually download any version

I’ve got the same problem, clickin on Install Engine goes to the library tab but then nothing happens and the ‘+’ button is greyed out. Any hints what can it be?


I took a look here and downloaded all the requirements and prerequisites. Now I’m able to download every single versione. Hope it can works for you too, probably I just needed to update my GPU drivers.

Ok maybe I’ve found a way, not sure if it works for everyone.

I went to my app data folder:


And delete all folders in Local and Roaming starting with Epic and Unreal. This would reset all the launcher config and force it to redownload everything from scratch, 30 seconds after going to the library tab I was able to click on ‘+’.

I hope this helps.

1 Like

I have the greyed out “+” button too, but I have previously installed UE4.26.2 through the launcher so it used to work…

I haven’t touched the launcher since, until tried to get UE4.27 today and it wouldn’t let me. Maybe it got broken by an update?

Unfortunately this didn’t work for me. I also tried uninstalling the launcher and reinstalling with the latest MSI. That didn’t help and deleted the UE4.26.2 install as well. Ran the launcher as administrator to see if that helped, but no luck there either.