Unreal engine looks like its loading, but then nothng happens on win 7 64-bit

#launch-error
So I have a win 7 laptop with 8 gb ram. I finally installed the engine, but it dosent start. it shows the loading screen, loads to a 100%, then nothing happens. in task manager it shows that the program is still running. also, while starting I get an error message that me api-ms-win-core-winrt-l1-1-0.dll file is missing… I have tried to uninstall it and install the new 2015 version, but the problem still persists. if anyone can help me out, I will be ever so grateful. if you need any more data regarding this, please ask, and I will try my best to help.
Other details:-
1. win 7 does is not supported by python 3.10, so I used this Unreal Engine 5 crashes on Python plugin preload
----> this one-----> Release v3.9.1win7-1 · NulAsh/cpython · GitHub
2. these are my pc specs
Processor ---- Intel® Core™ i7-4600U CPU @ 2.10GHz
Graphics ------ Intel® HD Graphics Family
OS -------- Win 7 professional

You need windows 10 minimum spec for UE5. I would assume the dll is actually apart or windows 10/11 as a dll is shared code for any program to use.

1 Like

True it says minimum requirements are windows 10, but it seems that people have been able to run it on win 7 on multiple forums

Hello,

It can definitely run under win7. The one thing you need to do is to try and locate copies of any Dll requested on launch. Once that is done you’ll only have a couple popup warnings to OK on startup and you’ll be able to run the editor and use all the features, outside of some DX12-specific ones.

That said your integrated graphics card may cause other issues, not sure.