Unreal Engine launcher isn't allowing me to open up project files. What can I do to fix it?

I have a problem opening up the 4.21 project. I have an environment I’ve been creating but I cannot open the project for some reason. The epic launcher crashes every time. I’m not sure why this started happening because it was working alright a week ago. Now, the launcher just restarts itself when I try to open a project file. I have tried to reinstall 4.21, but it was unsuccessful. Still cannot open up the project file.

I am also having this issue, I can’t even open my 4.19 projects or start a new project. It just crashes every time after the preloader runs for a bit and then nothing at all. Everything was fine a few weeks ago and now I got diddly squat and not a single google search is helping me. So you’re not the only one having this issue, I hope someone responds to this.

  • Have you tried opening the actual .uproject file without the launcher?
  • Do you have older engine versions installed? if you do, try and open up with an older version (right-click on the .uproject file and select “switch unreal engine version” and choose an older version. This will only work if you didn’t open the project in an earlier version.
  • Did you try opening the launcher and verifying the installation?

Also, try updating the launcher version (if you have any orange small dots next to “settings”

Let me know if anything worked.