Unreal Engine got blac

Hello there,

after pressing a button on a UMG gui, the Unreal Editor suddenly turned black (see image).

I am thankful for any help.

Best regards,
Sky

Hello PyxtonStudios,

I was not able to reproduce this issue on our end. I have a couple of questions that will help me narrow down your issue:

  1. Can you reproduce this issue in a new project?
  2. If so could you provide a detailed list of steps so I can reproduce this issue on our end?
  3. Could you provide screenshots of your UMG?

Thanks!

Hello Thomas,

Thank you for the answer. We already soved the issue. I would like to provide you a solution to solve this issue without the use of a backup, but unfortunately here is what we did:

  1. Load a backup from the day before.
  2. Updated all the files we added/modified/… after the backup.

Now everything works well. Even the UMG gui works properly. The issue was really weird because restarting the computer didn’t helped, so it was no graphics issue.

Best regards,

Sky Haubrich

Update: Now after pressing the “Start” button to debug the game in the preview window, the Unreal Engine turned black again. This is weird.

Update: We found out that this always happens when we change the volume of the game in the main menu and hit “Apply”.

I have a couple more questions, that will help me continue my investigation of your issue!

  1. What version of Unreal are you using for this project?
  2. Could you provide screenshots of your UMG Designer and Graph?

Thanks!

Hello Thomas,

We are still working with Unreal 4.7.6 because when updating the project, there are too many issues.

But we found out what the issue was. The problem occurs when we save the new game settings because it always sets the gamma value to “0.0”.

I don’t know why this happens to the Unreal Engine but anyways, when setting the gamma value back to “2.2” everything is alright.

Best regards,
Sky