Download

Unreal Engine Freezes Mac M1

Hi

I’m using the new Mac mini with the Unreal versions 4.26 and 4.25

Both freeze my machine when I use the the view port (3rd person character blue print)

This happens very often and means I need a hard reboot

UE4 has not been updated to support the M1 Mac natively so there’s no guarantee that it will work properly.

Yes same here. i have tested 4.25 and 4.24 no chance - crashes freezes after a while. … i hope we get an update soon …

same here. both on 4.26 (which doesn’t render properly, everything has a weird shade of red unless using iOS preview), and on 4.25 (which renders properly, but still keeps crashing).

Unreal Engine 4.26.1 Macbook pro M1 16gb ram

The problem is not solved.
After 10-20 minutes of work, the screen image freezes due to the unreal engine!
CMD + TAB can work in the background (seen on the panel), video on youtube, but the screen image hangs.
It can only be solved by rebooting.

  1. Will this be fixed?
  2. Will the UE be compatible with the M1?

Everyone I have found a solution. (At least for the Mac mini I’m uncertain about the others) I have been using the M1 Mac mini as my sole dev device for the last month and after much research to which I found no solutions I finally found one myself. Whenever the screen freezes, which happens a lot. Instead of force rebooting like I’ve made a habit of doing daily, simply unplug the HDMI and plug it back in. It’s so stupid but it’s honestly that simple. I am now able to work for hours with no issues thanks to this, and I hope it works for you all too.

Still happens for me - it froze after 5 mins, then one time your HDMI trick actually worked, but then some 10 mins later it froze for good… only hard reboot worked.

I don’t have hdmi, only type-c.
Have you seen from the logs what happens at the time of the freeze?

**isaacpaullanier: Thank you for this tipp. it worked for me but I got a flickering in the editor. After closing and reopening it worked for hours. this is a really strange thing:-) **

Hey, I’ve been having the same issues but i’ve found a solution for now : Version 4.19.2 does work perfectly with my mac mini M1 :wink: Enjoy

so is this still happening for you guys after 11.2.3?

Still happening here on 11.2.3

I’m happy to report that I’ve found a better workaround instead of unplugging the HDMI.
Apparently just locking the screen works. You can use Control+Cmd+Q or Option+Cmd+Power shortcuts to lock the screen. After unlocking, you can continue working normally.

in my experience UE has always been a disaster on mac

i gave up using it a few years ago when STILL you couldn’t publish any UT maps you;d made on mac

anyways that’s water under the bridge now as UT has died a death

updated to mac os 11.4 and the problem seems to be fixed for me in ue 4.25.4

1 Like

it works.thank you.