Unreal Engine freeze when Saving

suddenly have freezes when “save all” / “save current level” (5.1.1 and also 5.2.1)
Must kill UE5 in task manager afterwards

only “save current level as…” works!?

I have done the graphics driver update.
also reinstalled Unreal Engine , problems remain

also saving meshes produces the freeze if the level has not been saved as… yet

No crash log is created


Hey there @PatMotZ! That’s an odd one! Only saving the level to another file is working? May I know your specs? There’s an issue I’m tracking now with saving/loading data on the recent windows 11 updates causing freezes in 5.1+. Can you save any data? For example compiling a BP and saving it via it’s own save button or saving edits to a material?


exactly, only “save current level as …” works, i then overwrite the file again and again.
also auto save and “chose files to save” works.

Save all = Freeze
Save current Level = Freeze

short test with Compile BP and Save BP = works
saving edits to a material = works

And now CRASH LOG are created; should I attach one?

Windows 11 Home
AMD Ryzen 7 5800H with Radeon Graphics 3.20 GHz
64.0 GB RAM
NVIDIA GeForce RTX 3070 Laptop GPU

That is interesting! Overwriting the file fails when saving but overwriting it externally succeeds.

Ahh good! Adding that to the bug report when we’re done digging here as well would be great. Yes, we can look into the logs to see if anything can be found. You can attach them as a file or a snippet with

``` code/large snip goes here ```

to make Things and stuff

One more question, if you take an actor in editor, select it, then try to make a BP out of it and see if it freezes as well? (this is related to a different issue).

yes, creating a blueprint from a static mesh actor freezed unreal engine too;
Here is the corresponding crash file

Aarburg_2_2.log (358.0 KB)

and here the chash file of a freeze during save mesh;

Aarburg_2.log (165.5 KB)

(Partially reproducible)
but now it’s getting very weird; since today, after I did the make a BP from a mesh, the problems with “save all” and “save current level” are gone ?!
only the “save Mesh” (only without previous “save level” or “save all” )still leads to the crash (and the already mentioned “make BP”)

but after a restart of the Unreal Engine the problems are back;

Aarburg_2.log (149.0 KB)

Thanks for the logs! So most of the logs don’t have much relevant information besides the blender plugin is struggling a it but that’s not likely your issue. If you take a look in the logs, 2 of them show a crash context GUID like this: UECC-Windows-2E12A0984471EB1CD1EA2EBA0CB59A63 if you check your ProjectFolder->Saved->Crashes you should find a corresponding folder with an XML crash context (mostly useless but sometimes has good hints) and another log file that might have what we’re looking for. Could I get a look at both of those for the 2nd log you sent? (GUID: UECC-Windows-2E12A0984471EB1CD1EA2EBA0CB59A63)

Here the xml files

CrashContext.runtime-xml (127.8 KB)

CrashContext.runtime-xml (106.4 KB)

Now a good / bad news
in the same project, even in new levels, the described problems suddenly disappeared again.
All Save and BP functions work again!

No changes were made to the system or the software…

And there it is again; after a “convert actors to static mesh” there was a freeze again, and from then on the problems were back, as before.

Unfortunately no more crash files

after a save current level all seams ok again

Great news that it was previously working for a bit, bad news is that it’s referencing the force close as the problem so there’s not so much context on the issue itself. It’s referencing the generic ntdll which is just basic operations.

To glean anything we’d have to go through full debugging with the dump file, it’s a bit involved if you’ve never done so before. I have a video that can help however if you’d like to attempt it! Requires both editor symbols and the project that’s erroring. If this is not possible, let me know and we can try to find a better way:

Disclaimer: One or more of these links are unaffiliated with Epic Games. Epic Games is not liable for anything that may occur outside of this Unreal Engine domain. Please exercise your best judgment when following links outside of the forums.

@SupportiveEntity , hey i have exactly the same problems:

  1. only “save current level as …” works
  2. if you take an actor in editor, select it, then try to make a BP out of it it freezes as well.

I really hope there´s asolution for this soon, I´m going crazy with this, i just can´t work .
I´m already considering moving to a different software cause of it

Hey there @jrojas97! Welcome to the community! Is it consistent every time you launch the level? Could you attempt to copy everything in the level, and pasting it into a new level to see if the new level is able to be saved regularly? Did you edit any engine side assets that are currently in the level? Does Unreal have access to the location the level is?



I got this issue now as well. Sometimes it will go up to 75% then freeze, sometimes at 0. One example where it freezes.

Hey there @KHM3dia!

Which version of UE is this occurring?

Does this occur in other versions?

May I know your specs?

Does this occur on the same asset each time or different ones?

Using 5.3 Preview 1.

So far never happened before, literally just started today.

My Specs: AMD Ryzen 9 3900x
ROG Strix X570 F
Nvidia 3080.

Seems to have started when I migrated some assets from an older project but I deleted them and reimported them fresh from their source and still happens.

Heya, just checkin in to add myself to the list of people experiencing the issue. I’m using UE 5.2.1, suddenly a project that was working before could not be saved through the “Save all” button, editor freezes and I have to kill the process from task manager.


“save current level as…” works

… Once. The second time I tried it freezes as well. Really don’t know what’s happening, the editor is not usable anymore in this way.

@SupportiveEntity Do you have any kind of news or workaround for this?

System specs:

Windows 11
Ryzen 9 3950X
RTX 3070 - RTX 3060 Ti

Hey there @Gono! Unfortunately I haven’t come across a solid workaround for this issue, and since I cannot replicate it it’s tough to even test some possibilities.

Is your project migrated as well? If so, from what engine version?

I’ve had a similar issue just occur, not the same but I’ll post this in case it helps someone else. The engine froze while doing an auto save which caused me to shut it down using task manager. When I reloaded it, I had lost all of my textures that I’d imported since the last manual save, this meant all of the materials that used these textures were broken (thanks auto save, not only do you constantly interrupt my work flow, but you stitched me up proper!!)

Anyway, I tried to add the textures back in, but when saving the material and the engine froze again!

So, I shut it down again, and opened the epic games launcher, in the drop down menu for the UE version, you can select ‘verify’, this seems to check the installation for errors and fixes them, it seems to fix a lot of issues that I’ve encountered. I’m not sure what it checks but each time it seems to install something, I’m wondering if the installation gets corrupted when running different versions of it and ‘verify’ seems to fix it.

1 Like

Exactly the same issue here, cannot “save all” all of the sudden in a project.
Even created a fresh project and imported only a few blueprints over, it was letting me “save all” for a little bit and then it froze about 10 minutes into the project.

Now whenever i open the project, move one of those starter cubes for example, then it already wont let me “save all”. Extremely frustrating :frowning:

Using UE 5.3.2

Hey, I just want to say verifying the engine worked for me.

1 Like