Unreal engine file does not have an associated app

I get this when I try an open a project.


I already have unreal engine installed

Go to the “Default App” settings of Windows and scroll down to click on “Choose default apps by file type”.
Scroll down to .uproject and when the explorer window comes up browse to [Directory of Epic Games Launcher]\Engine\Binaries\Win64\ and select the UnrealVersionSelector.exe

1 Like

When I click on it I get this:alt text

Then right click your .uproject and select “open with”, then browse to the .exe mentioned in my answer and mark “always open”


Invalid command line

Meanwhile I want to say, that you can start the engine first and then browse to the project to open it.
Maybe this already fixes the problem.

1 Like

hey did u menege to fix this i got the same result

I manage to get it to work by opening the .uproject file through the path Epic Games\UE_5.1\Engine\Binaries\Win64 then in the application UnrealEditor

Hi… I tried all that you have mentioned above, but I could not find .uproject in Default App, also i could not find UnrealVersionSelector.exe file… File is attached for your reference. Please help me to fix this.

In case anyone has issues in the future, this is the solution: Youtube

1 Like