Unreal Engine, Failed to read environment variables from XML file

Hello UE4 Answers!

Today I tried out Unreal Engine the first time but I didnt even came to the point where I could see the editor because the project creation fails because of an UnrealBuildException.

Running C:/Program Files
-projectfiles -project=“C:/Users/steelbloom/Desktop/MyProject/MyProject.uproject”
-game -rocket -progress Discovering modules, targets and source code for

UnrealBuildTool Exception:
ERROR: Failed to read environment
variables from XML file:

This happens when I try to create a new C++ project. Blueprint projects are created without any exceptions.
I made some research here and saw that Im not the only one with this problem, but none of the solutions provided in the internet helped me in any way. I reinstalled the UE4 and tried running the Launcher as administrator but that didnt fix it.

I found out that this exception has something todo with a syntax error in the “Path” environment variable, of which the content is here:
Path Environment Variable Content.

I looked through it, also checked the paths of the tmp.bat file, executed it manually but the tmp file stays empty.
When running the tmp7EB1.tmp.bat it throws an exception which states that “/Microsoft” cannot get edited syntactically at this point. My “Microsoft Visual Studio 12.0/VC/bin/x86_amd64” folder exists too, containing the “vcvarsx86_amd64.bat” (this bat file is originally throwing the “/Microsoft” syntax error I described above).

How can I fix this error as I really want to try out this great game engine with its build-in C++ usage.

Nobody got an idea? The error still occures and the “Path” environment variable doesnt seem to contain syntax errors.

Unfortunately I do not know the answer to this, but I got somewhat the same error, except that I can run the .bat file and the .tmp file gets filled. When I look at your path variables, the first line with double quotes also is the first line with microsoft in it, you might wanna try removing those double quotes from the path variable, if you hadn’t tried that already…

It worked, thank you very much! If you want you can propose your comment as an answer so I can tick it as correct.