Unreal engine/editor frame drop/stuttering issue

This is happening in standalone game builds, in viewport game demos, and in the editor itself. I do not have this issue outside of unreal engine. Approximately every ~1 second or so the fps will drop and then after ~100ms it will rise back up.

I tried profiling a standalone version of the game using unreal insights but all it shows is a Frame taking 100ms with 99% of that being ‘exclusive time’ and with more advanced logging it just shows the CPU is stalling. I’m not sure exactly what that indicates or how to go about fixing it.

This is all in a brand new installation on a brand new 970 evo plus nvme drive using a 1650 super/3770 i7/16 GB of RAM. It was occuring previously on an older but still well performed WD Black drive. It’s happening in every project I try (including new empty first person shooter/blank projects.)

I have tried a few different versions of nvidia drivers including studio and game ready editions. I have disabled nvidias in game overlay, I have disabled the steamVR plugin, I have tried with and without texture streaming, fixed framerate, framerate smoothing. So far nothing has helped at all, does anyone have any experience with this and any potential solutions to try? Thanks!

OK… It turns out it was due to having UDP Messaging - Enable Transport turned on. I do not understand why but thankfully I found the solution at this answer: https://answers.unrealengine.com/questions/964220/view.html

Well, I’m very happy it’s fixed at any rate. :slight_smile:

Wow, thanks a ton. Instant fix…Why is this even a problem?